Before a grow on a 8 TB RAID5, I am currently doing an e2fsck.

While the RAID was running w/o issues before (I switched from Ubuntu to CentOS 5.4 because I needed a specific hardware driver), the e2fsck initially turned up a boatload of errors (nohup.out is 7 GB), but after 5 days of continuous fscking, there have been no more outputs into the logs for nearly 2 days even though the process is still running at 100% CPU and 1.5G RAM. I tried an killall -USR1 e2fsck, but I still get no further outputs in my log.

Is it safe to kill e2fsck and retry with the -C option or will I make things worse? I have looked into the running times of e2fsck but from what I read by now it should have finished.


Until recently, I would have said that interrupting it was suicidal. However, five weeks ago, a colleague gaily interrupted a reboot fsck on a nastily dirty file system, before I could stop him. The FS was later fscked without incident. I have since, myself, interrupted several fscks on multi-TB file systems, because I didn't want them to happen yet, and I've not so far had any problems and when I redid them I used -C 0 as well.

As ever, Your Mileage May Vary, and whatever action you take is your own responsibility; but I was very surprised when my colleague got away with it, so I started to try it myself, and I've been alright so far. I thought that might be of interest to you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.