0

I've imported my old database (via phpMyAdmin) and everything seemed to be fine - except for the user/password combinations. I tried to do a "FLUSH PRIVILEGES" and afterwards, I couldn't login anymore into my root account either (which was working).

I tried to reset it via stopping the mysqld, starting mysqld_safe with the --skip-grant-tables flag and reset the root password. It returned no error message, but when I tried to login I still got 'Access denied'.

Any idea of what might have gone wrong?

Thanks a lot!

PS: This is on a Debian 5.0.6 System


EDIT: Somehow my root account was gone. I had to repeat the steps again, reset all the other passwords in the mysql.user table and add a new root account via

mysql> INSERT INTO user VALUES ('localhost','root',password('newpass'),'Y','Y ','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y', 'Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','' ,'','','',0,0,0,0);
mysql> INSERT INTO user VALUES ('127.0.0.1','root',password('newpass'),'Y','Y ','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y', 'Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','' ,'','','',0,0,0,0);

Now it's working again.

Thanks for all the replies! Cheers

2 Answers 2

2

just stop mysql [use kill if needed] and run it for a second with --skip-grant-tables option, change password for both root and debian-sys-maint password [so it matches one in /etc/mysql/debian.cnf ]

0
2

I don't know whether it does anything other than run mysqld_safe etc but I ran

dpkg-reconfigure mysql-server-5.0

and it gave me the option to reset the root password.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.