I've just been assigned a task of troubleshotting a softgrid setup, and since I've never worked with softgrid it's quite a steep learning curve.

A customer called in and said she couldn't start her simple application and that the softgrid icon said "Launch Failed" with the errorcode was "xxxxxx-xxxxxx0A-20000194".

After looking in the sftlog.txt at the terminalserver this is what I found:

The Softgrid Client could not connect to stream URL 'rtsp://foo:554/bar.sft' (FS status: 16D1380A-0000E005).

The Client was unable to connect to a SoftGrid server (rc 16D1380A-0000E005)

After this I've tried connecting to our SoftGrid server using both the SoftGrid Client Management software aswell as the Softgrid Management Console but to no avail.

Any thoughts on where to start looking? Couse I'm stuck. All machines (Terminalserver, SG-server, SQL-server) are running and working on all ports, I've doublechecked all the services aswell and can't seem to find anything.

(A reboot has been made on all machines aswell) The eventviewer doesn't show anything either.

Best Regards LP

  • Where is the App-V client running, on a Terminal Server or a end Client machine? Is the streaming server separate from the management server, is that separate from the terminal server? Are other App-V Apps running and just this one has issues, or is this the only one? Has it ever worked or is this a new installation? – Chris S Nov 3 '10 at 12:36
  • The App-V client is running on the Terminal Server, the streaming server is the same as the management server and separated from the terminal server. This is the only application currently running through SoftGrid and this have worked for years and just now it stopped working completely out of the blue. – user59054 Nov 3 '10 at 12:45
  • If SSL is configured, is the SSL Certificate on the Streaming/Mgmt server current? – Chris S Nov 3 '10 at 12:50
  • SSL is not configured, everything is port 80. – user59054 Nov 3 '10 at 12:55
  • The problem as I see it is that the "service" seems shut off, I just can't connect to it in any way at all. And since I've zero experience on this topic I've no clue where to start troubleshooting. – user59054 Nov 3 '10 at 13:03

The solution was too close to notice, the users windowsprofile had completely got fubar, so I rebuilt the profile and everything is sorted out. (As a sidenote, I could not log on the Managementprogram couse my user was only part of Softgrid Admins, I added myself to Softgrid Users and could instantly log on)

Thank you very much!

Have you checked out http://support.microsoft.com/kb/930614 - one of the potential causes is if the app isn't actually published to the user. Do you know how they get the icon? Is it delivered natively via App-V?

Not an answer to this asker, but I had the exact same error; 16D1380A-0000E005, and also logfile-entries. Leaving this for future googlers as the

I tried removing the pkg-file and entire client folder. I tried giving the user a new windows profile. I tried other SG apps, which worked. This app also worked for other users on same server.

One more symptom I had that is not mentioned here is that the app did not create a new pkg-file on attempted launch, but that is perhaps to be expected as it doesn't really get to launch.

The solution to by problem was to clean, unload and delete (yeah, paranoid) the app from the server. Then run and reload it. A nightly server reboot was also done.

After this it worked for the user, so it might be the reboot (can't see why) or it might be the reloading of the application.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.