When I check msconfig, there are no services that are blocked from starting up.

When I look in services.msc, the problem services have a start up type of 'Automatic', but have a blank space where others will show 'Started'.

Attempting to start them manually results in the following pop up error messages.

I have no idea what's causing this, looks like some sort of cascade effect from another problem service. It's affecting scheduled tasks, SQL server agent and windows back up services.

How can I resolve this? I don't know how to work out what the root cause is.

Task Scheduler Service Start Error: "Windows could not start the Task Scheduler service on local computer. 1068: The dependecy service or group failed to start.

SQL Server Service Start Error: "The SQL Server Agent service on Local Computer started and then stopped. Some services stop automatically if they are not in use by other services or programs."


I've just noticed some other services have a description of "Failed to Read Description. Error Code: 2"

They are:

NetMsmqActivator, NetPipeActivator, NetTcpActivator, NetTcpPortSharing

UPDATE 2: As joeqwerty says the Event Log service does seem to be the root of the problem. This service will not start either.

It fails with 'Error 31 - A device attached to the system is not functioning correctly'.

I've tried detaching all devices.

I've also followed the advice here, where the same problem is described, but with no luck:


Update 3

@ Pacey - The following was a good tip, really clear instruction. However, I found that those reg keys do not exist on my system.

"Your Problem might also derive from the UpperFilter or LowerFilter Settings of the CDROM Drive. These are a known cause for Errorcode 31. You can find step-by-step instructions on removing the filters on about.com"

I followed the advice through to checking every component in device manager separately, but everything is reported as working correctly!?

These services did all work at one point. The hardware set up hasn't changed much.

Guess I'm looking at a repair install maybe???!

  • Have you even checked the system logs? What do they report? Have you checked the dependencies? What is their state? It really sounds like you haven't even tried to help yourself by taking basic steps. – John Gardeniers Nov 4 '10 at 10:34
  • @John Gardeniers - I had done some research, but didn't want to start mucking around with registry keys without expert advice, hence the post. – gb2d Nov 6 '10 at 14:00
  • All the services you mentioned showing error are Windows Process Activation Services, check if it's installed and try to reinstall if possible. Looks like .net 3.5 is not good on your box. – Vivek Kumbhar Nov 6 '10 at 14:03

The most common cause is obviously that a service or servicegroup that is needed for task-scheduler failed to start.

So first thing you would like to check is which dependencies have beeon configured for the Task-Scheduler.


sc qc schedule

In Powershell:

get-service schedule | format-list name,ServicesDependedOn

The Schedule Service (afaik) depends on 2 services. The EventLog and the RPCSS. So if your scheduler has other dependencies try to set them back to default by issuing:

sc config schedule depend= RPCSS/EventLog

Your Problem might also derive from the UpperFilter or LowerFilter Settings of the CDROM Drive. These are a known cause for Errorcode 31. You can find step-by-step instructions on removing the filters on about.com

If this doesn't work I would suggest running

sfc /scannow

to check whether there are system files that have been corrupted.

  • Thanks, I ran the command in your last sentence, but didn't seem to do much. The event log service will not start. I have to admit, I don't really understand what that is doing. – gb2d Nov 4 '10 at 23:18
  • The command issues SC (Service Control) to configure the service named "schedule" (Task-Scheduler) and set its dependencies to RPCSS and EventLog Service. – pacey Nov 5 '10 at 0:45

As far as the Task Scheduler service is concerned, it depends on the RPC service and the Windows Event Log service, so take a look at those.

  • Thanks you are correct. Though I am unable to start the event viewer service. See my update. (I would +1 but don't have enough rep yet!) – gb2d Nov 4 '10 at 23:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.