About 2 month ago I upgraded my Dell Latitude E6500 laptop with a Corsair Force F120 SSD drive. Everything worked well until about a week or so back. I started the computer and was faced with a beep and a message saying "No boot sector on Internal HDD (IRRT). No bootable devices". Since I figured that the boot sector had somehow got corrupt I tried booting from the Windows 7 dvd in order to repair the boot sector. But the Windows 7 installation program only found a blank drive with 111GB of unallocated space. I panicked and brought the drive with me to work to let a colleague have a look at it. We made a disk image of the entire drive and ran the drive through Testdisk in Linux. Testdisk did not find any partitions. It appears that the drive has been completely erased...

What has happened? What is causing this behavior on an SSD?


Corsair F Series drives have a firmware problem that arises if you change system states. From another forum: "It runs fine as long as you don't try to put the laptop to sleep, wake it up, or change the hardware profile (say, by docking or undocking it)". Allegedly there is a firmware update to 2.0 which may address it along with having the latest BIOS and having AHCI set (vs IDE) in your BIOS. See http://forum.corsair.com/v3/showthread.php?t=90759


Call the vendor for support and/or RMA, and stand by for a restore from backup. (You do have a backup, right?)

  • I pretty much suck at backup so the latest backup is from mid september... – user59180 Nov 4 '10 at 13:17

Sounds like something that happened to me:

A systemcrash rendered the partition on the harddrive useless. I rebooted and startet up Knoppix to investigate further. I wasn't able to find partitions.

What had happened was that (after being unable to find something he thought was useful) a trim command got issued and the "useless" data got purged.

Problem with SSD is that SSD self is the problem. Many SSD failures are in fact unrecoverable - because if the remapping tables get trashed - the media data is effectively randomized - and mixed up with blocks which were marked as corrupted and unusable even before the SSD failed.

Hope you have a backup.

  • I have a backup but unfortunately it is not as recent as I'd wish. Should I return the drive to the store or can I reformat it and use it again or will the failure come back? – user59180 Nov 4 '10 at 14:56
  • As far as I can see you should be good to go with the old drive. You might want to use SSD-Life to verify this. You might also look at the Table found on this page if there is a wiping tool available. – pacey Nov 4 '10 at 15:12

This type of thing happens when the controller screws up somehow. The flash memory itself is fine, most likely, as well as the data on it but you can't get to it without a functional controller. Usually the only way to restore controller functionality is to re-flash the drive's firmware, which incidentally wipes out all your data. This is why I tell everyone who uses an SSD to be extra sure you do backups.

SSD manufacturers need to come up with a way to re-flash a controller without causing it to wipe the drive clean.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy