Previous PERC controllers could all be managed/monitored by the LSI MegaCLI tools. The latest release of those tools does not appear to recognize my H700 card:

$ sudo /opt/MegaRAID/MegaCli/MegaCli64 -adpCount 

Controller Count: 0.

Are there any options aside from installing the massive OMSA suite?



You didn't mention which "latest release" you used. I just tried this and it seems to work fine now. The Dell H700 is using this chipset:

# lspci -v | grep LSI
01:00.0 RAID bus controller: LSI Logic / Symbios Logic LSI MegaSAS 9260 (rev 05)

Visit the support section of LSI's site, the 9260 is part of the "MegaRAID Value Line". That took me to MegaRAID SAS 9260-8i, click on the "Downloads" tab from there. I downloaded "MegaCLI - Linux (MegaRAID Release 5.0)", version 8.01.06 from 28-FEB-11. Unzip the package, then install/run it like this:

# rpm -i Lib_Utils-1.00-08.noarch.rpm MegaCli-8.01.06-1.i386.rpm 
# /opt/MegaRAID/MegaCli/MegaCli64 -AdpAllInfo -aALL  

Adapter #0

Product Name    : PERC H700 Integrated
Serial No       : 0000000
FW Package Build: 12.10.0-0025

I blanked the serial number here for privacy reasons. You might need to do a firmware upgrade to your card as well to make it compatible. I wouldn't be surprised that this didn't work when you tried it and has only been fixed since. I try to hold off buying these new controllers from Dell until as long as possible after they've been released because of issues like that.

  • The latest release MegaCLI 8.07.14 opens /proc/devices to first scan for adapters. In VMWare ESX, this path does not exist. Try 8.07.07 instead. – parasietje Dec 9 '15 at 12:04

Have you taken a look at mdadm? See here for more information: mdadm

  • 2
    That is specific to software raid. – Insyte Mar 10 '11 at 16:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.