I added a 2TB drive to my system (NOT to my RAID 5 array, just an additional single drive), and now the array won't mount - I get a "mount: /dev/md0 already mounted or /media/storage busy" error. Everything's worked fine for 2 years. All I did was successfully update the MB bios, attach the 2TB Samsung hard drive, formatted it ext4 with a 1MB offset using a gparted bootable CD, then restarted my regular Ubuntu 9.10 system, at which point the array doesn't mount and I get the "mount: /dev/md0 already mounted or /media/storage busy" error.

mdadm says everything's still fine:

mdadm --detail /dev/md0 /dev/md0: Version : 00.90 Creation Time : Sat Aug 2 16:39:27 2008 Raid Level : raid5 Array Size : 2197715712 (2095.91 GiB 2250.46 GB) Used Dev Size : 732571904 (698.64 GiB 750.15 GB) Raid Devices : 4 Total Devices : 4 Preferred Minor : 0 Persistence : Superblock is persistent

    Update Time : Sat Nov  6 08:17:54 2010
          State : clean
 Active Devices : 4
Working Devices : 4
 Failed Devices : 0
  Spare Devices : 0

         Layout : left-symmetric
     Chunk Size : 64K

           UUID : 59d14b52:c05d4166:1246e5fe:589d0142
         Events : 0.3735628

    Number   Major   Minor   RaidDevice State
       0       8       17        0      active sync   /dev/sdb1
       1       8       33        1      active sync   /dev/sdc1
       2       8       49        2      active sync   /dev/sdd1
       3       8        1        3      active sync   /dev/sda1

scan looks fine too:

mdadm --detail --scan ARRAY /dev/md0 level=raid5 num-devices=4 metadata=00.90 UUID=59d14b52:c05d4166:1246e5fe:589d0142

But I can't mount it:

mount /media/storage mount: /dev/md0 already mounted or /media/storage busy

mdadm.conf still seems correct and matches scan output (and worked fine for 2 years until now):

# mdadm.conf

# by default, scan all partitions (/proc/partitions) for MD superblocks.
# alternatively, specify devices to scan, using wildcards if desired.
DEVICE /dev/sd*

# auto-create devices with Debian standard permissions
CREATE owner=root group=disk mode=0660 auto=yes

# automatically tag new arrays as belonging to the local system
HOMEHOST <system>

# definitions of existing MD arrays
ARRAY /dev/md0 level=raid5 num-devices=4 UUID=59d14b52:c05d4166:1246e5fe:589d0142

...and fstab looks correct (and has worked for 2 years as well):

# /etc/fstab: static file system information.

# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0

# /
UUID=4204d07b-c450-4461-a001-1ef6d4ecb1a3 / ext4 errors=remount-ro 0 1

# swap 
UUID=95331961-9abd-4795-9443-292146aca413 none swap sw 0 0

# RAID storage drive
/dev/md0 /media/storage ext3 auto,rw,user,relatime,noatime,nodiratime,exec,async 0 3

I'm at a loss for what to try next...

  • Sorry to ask idiot questions, but what's the output of "mount"?
    – MadHatter
    Nov 6, 2010 at 16:07
  • Oh, and "cat /proc/mdstat" would be useful, too.
    – MadHatter
    Nov 6, 2010 at 16:10
  • I don't think you're the idiot. This all started when I noticed the drive wasn't mounted on my desktop like it usually was. Then I cd'ed to it and it was there, but empty - no files. I rebooted, saw it still wasn't on my desktop, and I think at that point I (totally stupidly) decided it wasn't mounted and wrote this detailed, long, and now very embarrassing question. I just looked and it IS mounted and all my files are there. I have no idea what happened. Thanks for asking the obvious questions! Nov 6, 2010 at 16:28

1 Answer 1


check output of mount and cat /proc/mounts, looks like the FS is mounted

  • Yep. I was very confused - see my comments above. Nov 6, 2010 at 16:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .