I installed Ubuntu 10.10 Server on a very old computer (bought it in 2002), but it won't boot. It tells me it can't find the root mount volume by it's UUID and also gives me the follwing type of error:

Alert! /dev/disk/by-uuid/xxxxxxxx does not exist. Dropping to a shell!

After which it gives me a initramfs prompt. I've searched everywhere and I've found a lot of different solutions (editing my grub settings to NOT use a UUID but /dev/sda1 instead, this is infact the partition on which the installation resides)

I currently don't have acces to a keyboard or a monitor, but I'm doing everything via a LiveCD which has SSH enabled by default, so I can perform administrative tasks on the computer. The installation also should have SSH installed, so I can enter it through the network as soon as it's booted sucesfully. I also found a way to see what disks a computer has installed listed by their UUID, namely the following:

$ ls /dev/disk/by-uuid

Which I thought was an awesome way to check if the UUID which it was looking for was also in the grub settings. I am however getting a bus error when I try this command. Any idea why this is?

I also ran smartctl to check the disks for errors (there are two disks) the one with the installation on it does not report any errors, the one that doesn't does report errors, but I don't think this should be a problem. Should it?

Also I've tried setting GRUB_DISABLE_LINUX_UUID=true by doing the following:

$ sudo mkdir /mnt/hdd
$ sudo mount /dev/sda1 /mnt/hdd
$ sudo mount --bind /proc /mnt/hdd/proc
$ sudo mount --bind /dev /mnt/hdd/dev
$ sudo mount -- bind /sys /mnt/hdd/sys
$ sudo chroot /mnt/hdd
# vim /etc/default/grub
 -- editing the grub file --
# update-grub
Generating grub.cfg ...
Found linux image: /boot/vmlinuz-2.6.35-22-generic-pae
Found initrd image: /boot/initrd.img-2.6.35-22-generic-pae
Found memtest86+ image: /boot/memtest86+.bin
 -- exit; etc --

....probably because I'm totally stupid but totally desperate to get this system working from the hard drive. And it didn't help.

If anyone has any pointers, please don't hesitate. Thank you.

-- EDIT: here's my ouput from fdisk --

user@host:~$ sudo fdisk -l /dev/sda

Disk /dev/sda: 40.0 GB, 40020664320 bytes
255 heads, 63 sectors/track, 4865 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0007b4bd

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1        4661    37431296   83  Linux
/dev/sda2            4661        4866     1648641    5  Extended
/dev/sda5            4661        4866     1648640   82  Linux swap / Solaris

I also tried to update the initramfs, (this place gave me an impression it might be a good idea, even though I have a single-boot system and this is a fresh install). I did it pretty much the same way I changed the grub settings. Thanks for your replies. I'm just going to take out the second hard drive altogether, as I don't have access to my BIOS settings without a keyboard (or monitor). Tomorrow I'm getting those, to make things way less difficult.

  • Please show us your HD partitions using "fdisk -l /dev/sda". This is important to make sure the HD is partitioned as expected.
    – Khaled
    Nov 8, 2010 at 16:24
  • A broken harddisk can cause serious stability problems. If you know it's broken just disable it in bios and see if things improve...
    – pehrs
    Nov 8, 2010 at 16:36
  • Things didn't improve, I'm afraid. I disconnected the second hard drive (IDE slave; they're all IDE by the way).
    – pancake
    Nov 8, 2010 at 23:06

1 Answer 1


Solved it. It was the initramfs image, I backed it up, replaced it by running update-initramfs after binding dev, sys and proc to the directories on the hard drive and chrooting into it. Anyway, thanks Khaled and pehrs for your replies. Taking out the broken hard drive sped up the booting process as well. Also, now from the hard drive, it boots in 25 seconds!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.