I have a website that has ASP.Net Impersonation Enabled and Windows Authentication Enabled. When navigating to that site using IE8 with "Enable Integrated Windows Authentication" (under Tools -> Internet Options -> Advanced) checked, the browser pops-up a "Windows Security" dialog box asking for User name and Password. My understanding was that this was automatically passed through and I would not need to type in those details.

Additional Information:
If I uncheck "Enable Integrated Windows Authentication" I do not get the pop-up window and it appears to work was intended (though that is the opposite of what I would be expecting)
If I enable Windows Authentication in Firefox I do not get the pop-up window (i.e. works as intended)

Are there some settings or similar that could have been set to create this behavior? Or has anyone else seen similar behavior and know how to fix?


It looks like this is a similar issue to the item described here:

I was able to solve my issue using the Work-Around described here:

  • Just as a light-hearted aside, I wouldn't consider that second KB you posted to be a "work-around." I would consider services not being able to use Kerberos when they don't have an SPN registered in the directory and they're running as a local/domain user account "by design." :) – Ryan Ries Mar 13 '12 at 19:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.