I have Windows 7, VMware Worstation 7, and Ubuntu Hardy 8.04 client (I tried 64 bit client and 32). I have gotten phpmyadmin running on the host under Apache. I have changed the config.inc.php to add multiple hosts so I can access my MySQL instance running on a VMware Ubuntu Hardy client.

It is terribly slow. It takes 13 seconds to switch from one table to another. I have tried different instances of Ubuntu running different instances of MySQL. I have allocated 512 MB and also tried 1 GB memory. Top says the system is doing nothing.

Same problem on all. I tried changing from NAT to Host Network to Bridged Network. They all work but they are all equally as slow. I saw someone saying they had problems with non matching names in /etc/hostname and /etc/hosts so I have checked them. I access the host with hostname:


I have that in hostname and also in /etc/hosts.

top - 15:52:55 up 30 min,  2 users,  load average: 0.00, 0.00, 0.00
Tasks:  55 total,   1 running,  54 sleeping,   0 stopped,   0 zombie
Cpu(s):  0.0%us,  0.0%sy,  0.0%ni,100.0%id,  0.0%wa,  0.0%hi,  0.0%si,  0.0%st
Mem:    515432k total,   110748k used,   404684k free,     4980k buffers
Swap:   915664k total,        0k used,   915664k free,    64720k cached

Has anyone got any other idea?

  • I should add that I just installed phpmyadmin on the hardy client and when I access it from my host machine it flies. It seems like a problem accessing 3306 from host machine.
    – Rich
    Nov 9, 2010 at 5:14
  • And further when I run up 2 Hardy VMWare clients and one of them has phpmyadmin on, it can administer it's own mysql instance lightning fast but hit the other server and it is slow as anything. SO it is slow from windows host and from linux client. That means it's not a network issue as apache responds from host at lightning speed but 3306 is super slow. It's a 3306 issue isn't it? But what?
    – Rich
    Nov 9, 2010 at 5:43

2 Answers 2


I fixed it, well Google fixed it, it's always Google or Stackoverflow that fix it!

I added


to my.cnf in the [mysqld] section and thank goodness it worked! It now flies. It has taken me all day to get this development environment up and running, hopefully it will help someone else.




Rich -

Sorry - just saw this so figurd if it helps you tune this a bit better- why not answer.

I would start with some basic MySQL monitoring - a few tools that may help here are:

top, mtop and innotop

(top is default in linux) mtop - http://mtop.sourceforge.net innotop - http://innotop.sourceforge.net

You can also resort to the MySQL monitoring tool from the command line (cli)

mysqladmin processlist / mysqladmin proc

Sadly - many folks will use the default templates made available under /usr/share/mysql

I HIGHLY RECOMMEND SKIPPING THEM - they are old and not worth using for the following reasons:

  • Invalid settings for some OS or MySQL versions (e.g., thread_concurrency and skip-locking)
  • Adding huge array variables that you might not understand what they are
  • Performance from testing them against other settings are more than just questionable

After running those - and doing some tuning - let mysql run for at least 24-48 hours and then use the following diagnostic tools:

  • MySQL tuner (just type wget mysqltuner.pl in linux to download then chmod755 mysqltuner.pl and run it by doing ./mysqltuner.pl ;-)
  • mysqlidxchk (Install by wget hackmysql.com/scripts/mysqlidxchk-1.1 chmod 755 mysqlidxchk* mv mysqlidxchk* mysqlidxchk ) then run by doing something like this: ( ./mysqlidxchk --general /var/lib/mysql/ general.log )

If you need some help installing those as well please let me know

PS - most of these are linux only scripts - but will help a huge amount with the tuning and management of your mySQL server.

As well as a good log parsing tool like mysqlsla and mysqlreport for status reporting

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.