I've created an ASP.NET website and published it to a file from visual studio. Then I've copied my folder to the inetpub\wwwrot directory. Next under IIS I've converted this folder to the application.

Unfortunately, when I try to acces it like this: http://localhost/myappname I am getting 404 error. I was thinking that maybe IIS is not configured to process aspx files, but under http://localhost/default.aspx there is a working sharepoint website.

Have you got any ides where might be the problem?

  • Check that the default document in IIS is configured to be the document you want to be displayed. Either that, or make your document one of the default documents that IIS already recognizes.
    – user295745
    Jun 23, 2015 at 15:40
  • @ekummel - misconfigured default document will return an HTTP 403 Jul 31, 2015 at 16:58

1 Answer 1


IIS does provide detailed error message and 404 is very generic. If you could provide some more information about the error or a screenshot will help a lot.

You said you have a working SharePoint web site as a parent site, a new application within SharePoint handled web site will not work. You will need to exclude the folder through SharePoint to get it working.


I suggest you create a new appPool and then change your applications appPool to the new appPool. Your appPool's Managed pipeline mode should be configured to Classic

  • Thank you Vivek for your interest. The problem is that I do not get any more detailed information. When browsing Interenet I saw that some people get for example 404-3 and some more info about the error. I am getting just 404 saying that page has not been found and that I might misstype the URL. I am checking the Sharepoint 3.0 Define Managed Paths option and the thing is that I do not have Excluded Paths section, so I still do not know how to exaclude a given path...
    – Wodzu
    Nov 9, 2010 at 11:34
  • You are using IIS 7.0, are you sure you have WSS 3.0 installed? Nov 9, 2010 at 11:37
  • You can also try.. In IIS 7, create a new Application under the SharePoint Web Site, and select the Classic .NET AppPool as the application pool. Nov 9, 2010 at 11:41
  • Vivek, I am 100% about WSS 3.0, I've even read that creating a Virtual Directory on ISS 7 when you have WSS 3.0 should automaticaly exclude my website from mnaged paths. As for your second idea, I've chosen creating new application but I see some irrevelant options there like database name and authentication. I do not want to setup that :| I am almost 100% sure that this is the fault of WSS 3.0 since webpage is working on my local computer under IIS 7.5 where I do not have WSS installed...
    – Wodzu
    Nov 9, 2010 at 12:01
  • You can running the new application under WSS web site in a new appPool and then change the appPool to Classic .NET AppPool. Nov 9, 2010 at 12:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .