Have a bit of a GW problem, and I'm a bit stumped using the usual sources ( forums, TIDs, etc. ) even though the issue is theoretically quite straightforward.

The primary problem: I cannot set up a new PO on an OES2 sp 2 server that is already running an MTA. The secondary problem: The reason I cannot set up the PO appears to be an issue with setting up an SDD that the Linux server can access.

Platforms: OES 2 sp2 with GroupWise 8.0.2 (without the hot patch released a couple of days ago). All but one of my existing POs is hosted on Netware. The non-Netware PO is also on OES2 sp2 but I set it up about two years ago and my memory of the process has faded ....

My problem appears to be identical to this forum posting: http://forums.novell.com/novell-product-support-forums/groupwise/groupwise-8x/gw8-agents/423407-can-not-create-po.html

In Detail: I am trying to set the PO up at path /media/nss/MAIL/gwpost The gwpost directory is writable by both root and the eDirectory user I am using with ConsoleOne. I have attempted to use ConsoleOne (as installed from GW 8.0.2 media) from both the OES server itself and Windows 7 to create the PO. Everything goes well until I get to the last stage of the PO creation screens -- after clicking "Finish" the GroupWise installer tells me that it cannot access the SDD and gives me a warning. Even if I ignore the warning, it dumps me back to the first PO creation screen. I do not have a standard SDD for Linux GroupWise so I am creating a new one for this particular project.

So, all indications are that I have a bad SDD, but given the forum post I am not ruling out a GroupWise bug (that said, the recent hot patch does not seem to have any fixes listed that would solve this issue). I do know that Linux SDDs can be tricky.

Novell TID 7005157 goes into some of these issues: http://www.novell.com/support/php/search.do?cmd=displayKC&docType=kc&externalId=7005157&sliceId=1&docTypeID=DT_TID_1_1&dialogID=182591620&stateId=0%200%20182593086

I have tried the following: 1. Using the GroupWise installer and ConsoleOne to create an SDD at /media/nss/MAIL/software and attempted to access it via NCP share. 2. Using the GroupWise installer and ConsoleOne to create an SDD at /media/nss/MAIL/software and attempting to access it via the Linux path (with and without values in the UNC path per the TID) 3. Using the GroupWise installer and ConsoleOne to create an SDD at /opt/novell/groupwise/software and attempting to access it via the Linux path (without values in the UNC path per the TID)

All of these SDDs have resulted in the same error, per my description and the forum post above. I have checked the rights for both root and the eDirectory user for all of the SDDs above.

I've been working on this for two days and am stumped. Any ideas? Has anyone seen this?

  • If you've stumped the Novell forums, your chances of an answer here are small. @geoffc is probably the only one here who can tackle this. I haven't done enough GW on linux to help.
    – sysadmin1138
    Nov 10, 2010 at 18:06
  • Stupidly, I didn't post to the forums, only searched them and found that previous post with the same issue. Now I've cross-posted there (and also sent it to a mailing list). If you are stumped (I've been reading your blog for a couple of years), then this is starting to look like an SR. Thanks. Nov 10, 2010 at 18:51
  • Sorry I do more Identity Management and other Novell stuff. Not a huge GW guy. Though I do suggest the forums as there are some really good GW resources there.
    – geoffc
    Nov 11, 2010 at 3:14

1 Answer 1


Novell solved this one for me. Answering for posterity.

I was not connected to the primary domain for the system, and the secondary domain I was connected to did not have the wpoffice/nwguard.dc file available. Once that was added, the PO added fine. Hopefully a TID will come out of this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.