I have a simple website (http://localhost:8889) on Windows Server 2003 and IIS6. There is nothing in this website except a page called default.htm containing a simple text string. The page is served up properly if I specify .Net 2.0 on the ASP.Net page. If I specify .Net 4.0, the browser displays a page saying the server declined to serve the page.

The same configuration was tried on a WS2003 system running in a Microsoft Virtual PC and it worked fine.

(I'm trying to deploy an MVC site that requires .Net 4.0, the question is distilled down to what I believe is the fundemantal problem.)

Can anyone help?



Turns out that .Net 4 and .Net 2 sites can't use the same user process. (I found an error in the Applicatin event log.) All I had to do to fix the problem was create and use a new app pool for the new site.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.