9

Intermittently we get a problem where a remote desktop session will get disconnected with the error message “Because of a protocol error, this session will be disconnected. Please try connecting to the remote computer again.”

We are getting this with one server only which is running Windows Server 2008, connecting with Windows 7 clients. The session itself stays running, you just get disconnected, and you can try and reconnect. Sometimes you get in for a while then it will kick you out.

We are connecting from Windows 7 clients. We have tried connecting using Cord on a Mac and this works fine, so it's not like the session itself is corrupted.

One problem is that there are some critical applications running under the session (I know, let's not discuss the idiocy of that), so we cannot reset the session in any way during the working day – so any diagnostics must have minimum impact.

Thanks, Jon

  • Is this happening with all of your windows 7 client? – Not Kyle stop stalking me Nov 11 '10 at 17:18
  • Yes - once the session is in this 'state', I can't connect from any Windows 7 client (I don't have Vista/XP to try). I can connect using Cord from Mac or some other open source product on CentOS. – Jon Nov 15 '10 at 8:55
2

I had the same issue and luckily I found the solution on the social.technet.microsoft.com forum:

... Change the RDP Compression setting on the server to "Balances memory and network bandwidth" (recommended) or "Optimized to use less memory" using Group Policy.

  • Thank you! I will try this the next time it occurs. I've had a paid support case open with Microsoft for months now...jumped through 100 hoops with no resolution. I'll report back the result the next time the error pops up. – Jon Mar 15 '11 at 14:08
2

This is normally caused by low RAM availability / full system volume or swap-file drive being full on the system you are trying to connect to.

1

This problem may occur due to low memory on the remote server.

For me, doing the following fixed the problem:

  1. Go to the Experience tab, and disable the following:

    • Desktop Composition
    • Visual Styles
    • Persistent bitmap caching
  2. Go to the Display tab:

    • Set a smaller resolution
    • Lower the color depth (for example 15 bit)
  3. Also, if you don't need the remote audio, go to Local Resources tab:

    • Click the Remote audio -> Settings..., check Do not play and Do not record

No need to change the RDP Compression from the Group Policy on the remote machine, only disabling these should do the trick.

Tested to work on Windows Server 2008 R2 SP1 as the remote, and Windows 10 Pro as the client.

0

A possible test is to see if this occurs with Windows 7 clients connecting through a different IP network/subnet (if the current situation occurs with local network clients).

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.