20

'exportfs -r' returns me this error when I'm trying to export /home/user/share (ext4):

exportfs: Warning: /home/user/share does not support NFS export.

/etc/exports:

/home/user/share 192.168.1.3 (rw,no_subtree_check)

The system is Ubuntu 10.04 with nfs-kernel-server package. Any ideas why this is happening? Is it because of ext4?

3
  • This may be a related bug. bugs.debian.org/cgi-bin/bugreport.cgi?bug=602956 Have you considered using a user-space NFS server?
    – Zoredache
    Jan 5, 2011 at 3:35
  • Same problem on ubuntu 11.04. Can't export dir in encrypted home dir, but if i create a new dir e.g. /exports it works fine with nfs.
    – user87939
    Jul 17, 2011 at 19:19
  • 1
    OP can you accept my five years old anwser as the correct one? Cheers. Nov 22, 2017 at 7:57

5 Answers 5

29

nfs-kernel-server cannot work with a FUSE folder like an encrypted ecryptfs home directory.

5
  • 1
    Can you explain why that is so? Are there other nfs server packages that would work with FUSE? May 10, 2013 at 6:50
  • An user-space NFS server like UNFS3 may works unfs3.sourceforge.net May 10, 2013 at 8:05
  • 1
    I've tried to find a NFS4 version of that, with no success. Anyway, thanks for the info. May 11, 2013 at 0:29
  • 1
    you should accept this reply as the anwser to your question. Nov 30, 2013 at 8:34
  • 2
    eCryptfs doesn't use FUSE, but you can't export directories inside eCryptfs with NFS anyway. Mar 17, 2016 at 12:49
4

After some time I think I have solution. Due to NFS doesn't work under encrypted directory and this is probably only your home folder, you must move your directory to unencrypted space. In my case I've move vangrat project dir from /home/me/vagrant/project > /var/www/vagrant/porject. And boom, is working!

Also you can try play around and turn off encryption in your home folder but this is up to you.

Hope this is useful.

2

Had this problem due to a space in the path. Renaming the folder to remove all spaces resolved the issue for me.

0

Having a similar issue with 10.10. I believe it has something to do with having your export file system encrypted.

0

For me the problem was I was trying to use NFS with an external disk that was formatted with exfat.

Reformatting the disk to ext4 worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.