I've a Windows Server 2003 installation on VMWare Server 1. Using the instructions at http://ian.blenke.com/vmware/vmdk/xen/hvm/qemu I converted this virtual machine to a Xen image (Xen 3.3). However, I still get the 0x000007b bluescreen. As the domU reboots right away I have a hard time seeing any additional information, but I guess it probably is related to the whole scsi/ide switch.

Is there anything else I can do? For starters, keeping the blue screen visible would be a nice start. Also maybe any drivers missing in Microsoft's kb 314082 article (see link via above one) that I need on Xen 3.3?


Have you tried booting the VM with a Windows 2003 installation CD and attempting a repair of the installation it finds?


It could be that Windows does not like the change of system architecture, either because you have moved between host machines as well as moving between VMMs, because you have gone from single CPU to virtual SMP (or vice versa), or just because VMWare and Xen present the hardware differently.

I don't know about 2003 in this respect, but Windows 2000 and NT had different HALs (Hardware Abstraction Layers) for single processor and SMP systems and a few other circumstances and only installs the right one at install time so if you change the underlying hardware it might not cope. There are ways to change the HAL post-install though I can't remember how off the top of my head.

  • 1
    I did adjust the hal.dll file as per the instructions in the link I posted. Prior to doing that I did not even get a bluescreen. – Steven Jun 5 '09 at 5:06

I bet it's because the boot drive changed from Windows' point of view. IIRC, Windows doesn't deal well with the boot drive changing out from underneath it.

  • Yes, that's exactly my suspicion. But how do I fix this? – Steven Jun 5 '09 at 5:06

It may well be the virtual disk controller; I've run up against that when virtualising Linux servers.

  • Yes, that's exactly my suspicion. But how do I fix this? – Steven Jun 5 '09 at 5:07
  • Are the drivers for whichever VMWare adapter you're using installed? I think it's either BusLogic or LSI Logic. Some kind of logic, anyway. Failing that, you could try booting the VM off a Windows installation disk and repairing it. – RainyRat Jun 5 '09 at 7:54
  • Yes, of course they are installed, after all this machine was running in VMWare for 2 years!!! But I want to use it on Xen now and part of that is a switch from SCSI to IDE. Also see the links in my question. – Steven Jun 5 '09 at 17:43

i think u should try this , hope this will solve problem http://kb.vmware.com/selfservice/microsites/search.do?cmd=displayKC&externalId=1005208

  • Welcome to Server Fault! Generally we like answers on the site to be able to stand on their own - Links are great, but if that link ever breaks the answer should have enough information to still be helpful. Please consider editing your answer to include more detail. See the FAQ for more info. – slm Apr 27 '13 at 14:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy