EC2 will not accept RDP connections. On windows, I am using RDP to connect to my EC2 windows instance. But on the step where I see "configuring session..." , a second or two later the connection is terminated. Why is this happening? It was working a few hours ago.

  • Is remote desktop enabled on the EC2 machine you are connecting to? Nov 23, 2010 at 21:02
  • Well, restarted the instance. Went fine.
    – Wajih
    Nov 24, 2010 at 17:58

1 Answer 1


I had two times problems with connecting RDP to EC2

1) The first time I contacted Amazon Support and they told me they had a problem with the underlying hardware (although the portal gave a green running status). They advised me to restore my own backups. Weird enough, it worked again after a few days. I think it was a network issue.

2) I just rebooted the EC2 machine several times (like 4) and then I worked again.

I experienced issues with VPN products from LogMeIn Hamachi and Kerio VPN. Make an appropriate backup before you install this software.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.