Ok, so in an effort to keep things running smoothly, this weekend our company restarted the Linux server our Internet site was running on. Come Monday morning, we can't get to the site. I can ping the computer, but I don't know how much that is worth. It's a Linux Red Hat Enterprise 5 box running Apache and Tomcat with a Java website. Unfortunately, the person who previously managed the site no longer works for the company and is not within reach at the moment. And before he left, he didn't have time to update any of us developers or IT people that were left. We believe there may be a startup script to start the services, but we're not fully sure. I'm not expecting someone to tell me exactly how to fix this, but if you could help with some of these questions, I'd appreciate it.

  1. How do I verify Apache and Tomact are running on the server?
  2. Where on Linux would be the directory that a script could be placed to run on startup?
  3. I see Tomcat in the usr/local and tried running startup.sh/startup.bat from the bin directory but nothing happened. Should I try running that from the command line or is the GUI fine.
  4. What order is it best to start the services?


Thank you all for your help. The guy finally called us back. Much appreciated.


Do you have your predecesors phone number?

  • He is out hunting. :) But yes, I do, and we've tried that, MANY times. Even sent emails. – XstreamINsanity Nov 15 '10 at 16:26
  • @XstreamINsanity - not answering php chances for email reading is even smaller – ajreal Nov 15 '10 at 16:44
  • Do you know if he left on good terms? – Jaydee Nov 15 '10 at 16:45
  • Yes, he left on good terms, but if he's like other guys I know that hunt, there is no way to reach him until he goes back home. :) – XstreamINsanity Nov 15 '10 at 16:48
  • He finally called us back. He's working on it. Thanks. – XstreamINsanity Nov 15 '10 at 17:26
./catalina.sh start &
  • From the tomcat bin directory? – XstreamINsanity Nov 15 '10 at 16:01
  • yeah, thats how we used to do it. And btw a bat file won't work on unix. – NimChimpsky Nov 15 '10 at 16:02
  • Is it preferred to do it from putty or the actual machine? – XstreamINsanity Nov 15 '10 at 16:03
  • it makes no difference if putty or not, if you put ampersand at end of command it it will start as background process (which is probably what you want). But tbh the only proper solution is to get your technical guy back. – NimChimpsky Nov 15 '10 at 16:07
  • Believe me, I wish we could. Because he was a manager, his last two weeks were nothing but meetings, leaving me and my co-worker in the dark. Today is his first day gone. – XstreamINsanity Nov 15 '10 at 16:13
  1. ps -ef | grep apache
  2. /etc/init.d
  • I went to /etc/init.d to try and looked for anything apache or tomcat, but there's nothing there. Should I look for something sh or bat? Also, the "ps" returned 9 items, 8 having /usr/sbin/httpd, the other being my search. How can I use that to find something out? – XstreamINsanity Nov 15 '10 at 16:01
  • 1
    bat files are for windows not unix, they are ms-dos batch files. sh is a shell script for *nix. – NimChimpsky Nov 15 '10 at 16:11
  • That's what I figured but when I was looking through the gui, I saw a few bat files and wasn't sure if there was something new I didn't know about. Last I used Linux was 7 years ago. – XstreamINsanity Nov 15 '10 at 16:14
  • if the ps got back 8 results, then one of them is most likely the parent Apache pid, and the others would be forked child processes. the ps will show you the parent process for each of these. but this means porbably your Apache web process is up. – JoseK Nov 15 '10 at 16:19
  • Ok, thanks. I was kind of hoping it wasn't. Now I have to find out what it is – XstreamINsanity Nov 15 '10 at 16:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy