I have a Lenovo W510 with windows 2008 R2 installed.

I run Hyper-V on this machine without problems, virtualization is enabled in order to do this.

I am now trying to run virtual box on this machine and get the error: VT-x is not available

Anyone know how to get this to work.


You cannot run Hyper-V and virtual box simultaneously. Any application that uses the virtualization-specific instruction sets on the CPU does so wholesale and therefore locks other programs out of using them. The only way to use another virtual software is to either deactivate Hyper-V or make sure that the software does not make use of the virtualization instructions. You'd have to check with the software developers to figure out how to do the latter.

  • Thanks for the answer. I tried stopping the 3 hyper-V services and setting them to manual startup, I then restarted the machine. Still did not work. Do I need to remove the Hyper-V role from the server? – Shiraz Bhaiji Nov 17 '10 at 13:14
  • 2
    @Shiraz, Hyper-V is not a service, it's a hypervisor. You need to remove the Role in Server Manager if you want Hyper-V gone (the same way you installed it, more than likely). – Chris S Nov 17 '10 at 13:37
  • @Chris, removing the Hyper-V role worked – Shiraz Bhaiji Nov 17 '10 at 21:24
  • There are messages that it is still possible: eightforums.com/virtualization/… Kari's post at 15 Jun 2014 – Roman Pokrovskij Feb 6 '15 at 12:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.