I'm retiring our 10 year old web server (no more Pentium III - yay!). A few of the pages on the web site it hosted have forms that cause e-mails to be sent to certain people. These e-mails are sent via the smtp server in IIS. We also use this smtp server for a few other things, including messages from our help desk software and e-mail alerts from some of our network devices. This is the only remaining smtp server on campus. The rest of our e-mail is hosted by Google Apps for Education. The server is set up with a smart host pointed at smtp.gmail.com and has a good username/password (with tls) to talk to Google's server. In other words, all it does is forward messages from software on campus to our mail system off campus.

Unfortunately, messages sent through this server are getting stuck in the mailroot/Queue folder. If I wait too much longer I expect they'll finally move to BadMail. As far as I can tell, this new server's config exactly manages the old config. My own investigations show that dns is working just fine (the most common suggestion for similar problems found online, to the point that it drowns out other ideas). The event log has the entries in the form of the following:

Message delivery to the host '' failed while delivering to the remote domain 'york.edu' for the following reason: The remote server did not respond to a connection attempt.

To me this sounds like either a firewall problem (I turned it off - no luck) or an authentication/encryption problem. I've triple-checked that the username and password are correct, and the TLS encryption option is enabled (as it should be). The new server is installed in hyper-v, and so for kicks I tried disabling the firewall on the host as well, but that hasn't helped.

Also, I am able to telnet smtp.gmail.com 25 and I get the expected 220 response. Of course, I can go no farther via telnet because it requires a STARTTLS command, but I do at least get that far.

Any ideas?


Okay, once again I missed the obvious. In setting up the smtp server, after making a change I would go to the root of my management console window for IIS and tell it to restart to make sure all the changes were applied. Unfortunately, this would not restart the smtp service, and my changes weren't making it in. Once I corrected this behavior I started seeing actual error messages, and correcting those was a snap.


That IP is a server owned by Postini according to a reverse DNS lookup and then by doing a whois search. The former does not seem to allow linking to results so you will have to search yourself.

Essentially, because Google acquired Postini, I expect that a long-term problem is not with their servers in light of their rather incredibly large server farm.

Given that the error message is from IIS, rather than a parroted echo of a message from some distant email server, I'd say you have network connectivity issues between your virtual server and the outside world.


telnet 25

I can connect to that:

Connected to
Escape character is '^]'.
220 Postini ESMTP 188 y6_34_1c0 ready.  CA Business and Professions Code Section 17538.45 forbids use of this system for unsolicited electronic mail advertisements.

..if you can't then your problem is network related.

  • I already know this won't work for me. We block outbound port 25 at the gateway. The server should be connecting over 465 (smtps) or 587 (tls) – Joel Coel Nov 19 '10 at 23:11
  • And if you change the 25 in my command to one you should be able to connect over, what happens? – Neil Trodden Nov 19 '10 at 23:27
  • I take it back: I can telnet on port 25 and I do get a 220 response. (this server gets to bypass the firewall for this traffic). But still can't send e-mail, same error. Updating the question with this information as well. – Joel Coel Nov 22 '10 at 15:44
  • Okay, the problem is resolved now. I'd like to upvote your answer for your help, but I can't until you edit your question (hint hint). It's just a quirk in the mechanics of how these sites work. – Joel Coel Nov 22 '10 at 21:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.