If you 'whois microsoft.com', you get a whole bunch of listings from pranksters who thought it would be funny to mess with the listings by putting 'microsoft.com' in their subdomains.

The output instructs:

To single out one record, look it up with "xxx", where xxx is one of the of the records displayed above. If the records are the same, look them up with "=xxx" to receive a full display for each record.

But this does not work as far as I can tell.

david:~$ whois '"microsoft.com"'
whois: com".whois-servers.net: nodename nor servname provided, or not known
david:~$ whois =microsoft.com
(...blah, blah, blah...)
 No match for =MICROSOFT.COM
david:~$ whois '"=microsoft.com"'
whois: com".whois-servers.net: nodename nor servname provided, or not known

So how do you do it?

I know I can go to a web site to look it up, but that's not the point.


There are several command-line whois clients in use on Unix (for instance, Debian and FreeBSD, by default, have two very distinct tools). So, without knowing the one you use, it may be difficult to help you.

The text you quote is appârently the one sent by whois.internic.net and it seems wrong to me.

Also, a fix, the microsoft.com.pranks are server names, "subdomains" is technically true but misleading.

  • 1
    I hadn't thought of this. As I wrote the question I was trying it on my Mac. I tried it again on my Ubuntu box and it works just fine. So, I guess the Mac (BSD inherited) version of whois is just old and broken. As a workaround, I installed the version of whois in MacPorts, which seems to be the same one that is common in Linux distributions. – David Jul 17 '09 at 16:40

Or using the advised method - whois "=microsoft.com"

  • i do get error using this method though - The Registry database contains ONLY .COM, .NET, .EDU domains and Registrars. No match for =MICROSOFT.COM whois version 4.7.24. – Martynas Saint Jun 5 '09 at 14:57
  • 1
    I have no problem doing 'whois =microsoft.com' from my Fedora Core system and returning a single result. But then I can also do it without the = and still get one result. My whois is using whois.verisign-grs.com – Kevin Kuphal Jun 5 '09 at 15:45
  • @Martynas, or maybe you skip the result. At the end of the output it does say "No match for =MICROSOFT.COM". Try whois =microsoft.com | more – user5824 Jun 5 '09 at 16:22
  • @daLizard - whois capitalizes, I guess the only reason Kevin gets single result is that he hits good whois server – Martynas Saint Jun 9 '09 at 7:30
  • @daLizard - Bare double-quotes are interpreted by the shell (bash) and not passed on as part of the parameters. The result is the same as without them. Hence my initial attempts at single-quote trickery. – David Jul 17 '09 at 16:34

whois microsoft.com -h whois.tucows.com


  • This requires you know the registrar Microsoft uses (or you do it in two steps, one to find the registrar and one to query it). Inconvenient. – bortzmeyer Jun 9 '09 at 7:18
  • 1
    actually it requires registrar which has authoritative information. whois utility can't guess it. – Martynas Saint Jun 9 '09 at 7:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.