3

How come I can ping back and forth between host and guest using VirtualBox, but I can't access from the host the web server installed in the guest. I'm using a host-only network.

Host Ubuntu 10.10 
vboxnet0 - 192.168.56.1
ping to self, works
ping to guest, works
access to web server in guest, FAILS

Guest Fedora 13
eth1 - 192.168.56.101
ping to self, works
ping to host, works
access to web server in host, works
2
  • It would help if we knew OS type, application type (Apache2, yes but is it a LAMP or WAMP setup)... What about subnetting or alike ? More info is needed Nov 24 '10 at 9:48
  • I chose host-only network because with NAT you must use port forwarding and I wanted to avoid that. Apparently port forwarding is needed with a host-only network too.
    – givanse
    Nov 24 '10 at 17:31
7

Check firewall settings and possibly access restrictions in httpd config on the guest.

1
  • Fedora comes with a firewall... I didn't know that...
    – givanse
    Nov 24 '10 at 23:06
1

Do you have a web proxy configured in your browser by chance?

I am also going out on a limb - can the virtual server access the local web server on itself? Is there a Linux firewall in place that is blocking access to port 80 from non-local hosts?

1
  • nop, netiher firefox or chrome use a proxy
    – givanse
    Nov 24 '10 at 21:39
1

What I found fixed the issue for me was making sure that the windows VirtualHost-Only adapter was set to the .1 address for the ip range so my virtual box host only adapter was 192.168.58.20 but the ip for the Windows adapter is 192.168.58.1

0

I checked the firewall demon on the guest and realized it was running and I stopped it and I could now access the Installed EBS (Oracle Enterprise Business Suite) on the host. See below:

[root@ebs]# systemctl status firewalld
● firewalld.service - firewalld - dynamic firewall daemon
   Loaded: loaded (/usr/lib/systemd/system/firewalld.service; enabled; vendor preset: enabled)
   Active: active (running) since Tue 2020-08-04 23:56:01 EDT; 20h ago
     Docs: man:firewalld(1)
 Main PID: 929 (firewalld)
    Tasks: 2
   CGroup: /system.slice/firewalld.service
           └─929 /usr/bin/python2 -Es /usr/sbin/firewalld --nofork --nopid

Aug 04 23:56:00 ebs.localdomain systemd[1]: Starting firewalld - dynamic firewall daemon...
Aug 04 23:56:01 ebs.localdomain systemd[1]: Started firewalld - dynamic firewall daemon.
Aug 04 23:56:02 ebs.localdomain firewalld[929]: WARNING: AllowZoneDrifting is enabled. This is considered an insecure configuration option...it now.
Hint: Some lines were ellipsized, use -l to show in full.
[root@ebs]# systemctl stop firewalld
[root@ebs]# systemctl status firewalld
● firewalld.service - firewalld - dynamic firewall daemon
   Loaded: loaded (/usr/lib/systemd/system/firewalld.service; enabled; vendor preset: enabled)
   Active: inactive (dead) since Wed 2020-08-05 20:14:31 EDT; 6s ago
     Docs: man:firewalld(1)
  Process: 929 ExecStart=/usr/sbin/firewalld --nofork --nopid $FIREWALLD_ARGS (code=exited, status=0/SUCCESS)
 Main PID: 929 (code=exited, status=0/SUCCESS)

Aug 04 23:56:00 ebs.localdomain systemd[1]: Starting firewalld - dynamic firewall daemon...
Aug 04 23:56:01 ebs.localdomain systemd[1]: Started firewalld - dynamic firewall daemon.
Aug 04 23:56:02 ebs.localdomain firewalld[929]: WARNING: AllowZoneDrifting is enabled. This is considered an insecure configuration option...it now.
Aug 05 20:14:30 ebs.localdomain systemd[1]: Stopping firewalld - dynamic firewall daemon...
Aug 05 20:14:31 ebs.localdomain systemd[1]: Stopped firewalld - dynamic firewall daemon.
Hint: Some lines were ellipsized, use -l to show in full.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.