I have 2 interfaces on my desktop: one in a multicast enabled vlan, that has access to some udp streams, but otherwise unrouted, and one with internet access, but no multicast.

If only the multicast interface is enabled, I am able to play the streams, with VLC, for example. If I enable the second interface, I loose access to the multicast stream.

This happens due to a routing problem, as far as I can think. So I need to route the multicast request (IGMP and such) through the right interface, or something like that.

Does anyone have any idea how to do this on Windows 7?


Have you tried moving the network card that needs to multicast up in priority?

  • Open Control Panel\Network and Internet\Network Connections
  • Press your ALT key, then choose the Advanced menu and select Advanced Settings.
  • Under Adapters and Bindings, move the multicast NIC above the Internet Access NIC in the Connections field.

Let me know if that works.

  • Glad that helped. – CurtM Nov 24 '10 at 17:33
  • +1. I was going to research the right syntax to add a static route pointing for the multicast range out the correct interface, but this solution is way better. – Jed Daniels Nov 25 '10 at 4:16
  • If you do this, wouldn't that make the gateway in the multicast enabled network your default gateway, causing all traffic without a specific route to try to go through that interface instead of the internet connected interface? – rantsh Sep 11 '15 at 2:29
  • 1
    Could someone tell me, how to do the same in Windows 10 Enterprise? – Sathish Apr 21 '16 at 13:18

I will just add one information to accepted answer. In Windows 10 there in not anymore this settings available. It is based on metrics. So in a case of Windows 10 you need to setup manualy the metrics for network adapters to achieve same thing as described in accepted answer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.