I went and upgraded our domain functional level to Windows Server 2003, then rebooted. Now I can't log in via remote desktop from any of the following clients:

  1. Haiku (rdesktop)
  2. Linux (KRDC)
  3. WinXP SP3
    1. on network
      1. built-in version
    2. off network
      1. built-in version
      2. Remote Desktop Connection 7.0
  4. Windows 7

However, regular authentication (i.e., not over remote desktop) from WinXP SP3 clients on the network works fine. Off-network, I can connect to the same server on other ports for other services no problem, and I haven't changed any port-related settings lately.

The error message, which appears almost immediately after clicking, is:

Remote Desktop Connection
This computer can't connect to the remote computer.

Try connecting again. If the problem continues, contact the owner
of the remote computer or your network administrator.
OK   Help   

The client is set to "warn me" for auth and "auto" for gateway.

I've tried with and without the console switch.

Apparently, raising the DFL doesn't necessarily break RDP. So I'm not sure what exactly the problem is. I've never had it break this way before, and raising the DFL is the last thing I did before I rebooted, and the only configuration change I can remember making.

Given all the ways we can still access the server, and that otherwise it's functioning fine, how do I fix it so I can log in via remote desktop once again?


Try restarting the remote desktop service. If that doesn't fix it try rebooting again. Sometimes the remote desktop service will not start correctly.

  • Yep, a simple reboot from the console fixed it. And this time I clearly had no ability to change anything on the server in between. Unbelievable. Thanks! – Kev Dec 1 '10 at 2:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.