We are sitting here in front of an ubuntu 10.04 server who insists doing a lengthy checkdisk during reboot.

We see one option to edit the kernel boot options line in grub to skip the check.

What would be the parmater, something like --skip-fsck maybe?

I am also trying google and docs and could not find it so far. Still searching...


With Mat's help (googling for fsck not chkdsk) i found the parameter, it is probably "fastboot", tried to edit grub during boot with that... still not found the right way to do it. Does it need -- in front? which line?


The boot process on ubuntu 10.04 is not like traditionally on linux, some things have changed to "speed up" the boot process. Obviously this results in the fact that fsck is no longer a foreground process that could be aborted with ctrl-c. There is pressing "C" mentioned, but this does not work, no reaction.


This is an Ubuntu 10.04 Server. I found this:

https: //wiki.ubuntu.com/LucidLynx/ReleaseNotes#Changes in boot-time output on Ubuntu Server

Quote: "Changes in boot-time output on Ubuntu Server

With the introduction of plymouth, boot-time messages from startup scripts are no longer displayed above the login prompt on tty1. Instead, they are all output to tty7 and on Ubuntu Server, can be viewed after boot by pressing Alt+F7. On all systems the boot output can also be found in /var/log/boot.log.

[...] Hotkeys for interacting with mountall will still work without the splash screen, but are not discoverable: C to cancel a running fsck; M to request a maintenance shell; S to skip an unavailable mount; and F to try to fix errors found by a fsck."

I tried c, C, m, M and Ctrl-C with no result. Alt-F7 sends me to a different boot log than Alt-F1, but both do not reaction, still fsck-ing.

I have the impression that the checking is done absolutely in the background. (upstart?) Cannot get control of that process. In the foreground the boot process continued to the other disks (which are clean) but stops then, but no ctrl-c accepted. Also no loging consoles available (alt-f2,...), only boot logs.

EDIT4: Maybe this is related information:


  • of course we will do the chkdisk soon and we will also switch this off but now it is too late for this time :/
    – GrubFreak
    Dec 1, 2010 at 14:02

4 Answers 4


fstab options /etc/fstab is a system configuration file and is used to tell the Linux kernel which partitions (file systems) to mount and where on the file system tree.

A typical fstab entry may look like this:

/dev/hda1 / ext3 defaults 1 1
/dev/hdb1 /home ext3 defaults 1 2

The 6th column (in bold) is a fsck options.
0 = Do not check.
1 = First file system (partition) to check;
/ (root partition) should be set to 1.
2 = ALL OTHER file systems to be checked.

But that is bad idea to stop checking disk . This is my mind.

  • This is great, thank you, we will definitely change on next successful boot according to your instructions!
    – GrubFreak
    Dec 1, 2010 at 14:25
  • if there is /boot and / on seperate partitions, which one gets the 1? and what gets the other one?
    – GrubFreak
    Dec 1, 2010 at 15:08

Assuming that by "checkdisk" you mean fsck, the kernel's not responsible for this; it's handled in user-space.

From recent experiments, I have found that it's safe to use CTRL-C to interrupt the fsck early on, and complete the boot process. You can then edit the options in fstab, as ntrance has said, or use tune2fs to retune the file system (assuming it's an ext[234] FS) so that more time (-i) or more mounts (-c) are required between mandatory fscks.


First off, did you try pressing C while in TTY7 or TTY1? Also did you try M for manual fsck? I believe those are hotkeys for the boot splash processor, plymouth, and not for mountall itself, and are implemented via plymouth's 'watch-keystroke' functionality.

However, if you really are experiencing a long fsck on ext3 or ext4, then the drive has most likely been marked dirty. This is probably because it was rebooted many times, and reached the maximal mount count between fsck's, or its been a really long time and reached the "maximum time since last fsck" count. Basically, the way the FS is normally setup, you need to do a full fsck every once in a while to clean out cruft.

Another option is that it actually found something terribly wrong with the volume. All of this should be reported somewhere in tty7's output.

In this case, with the volume undergoing full fsck, even if you interrupt the process, your system won't mount the volume, because it is marked as dirty. There are hacks to get around this, but for the most part, you're probably better off waiting for it to finish. You should see some kind of progress on TTY7 (alt-f7).


Edit the 'kernel' part of the boot options in GRUB, and change "ro" to "rw". This causes the root filesystem to be mounte read-write. Fsck does not like to check read-write filesystems, and it gets skipped.

For RHEL and CentOS, "fastboot" is the correct boot option.

Caveat: I haven't tested what happens if you have FSCKFIX=yes in /etc/default/rcS ... bad things could happen in that case.

Disclaimer: I don't know exactly which version of Ubuntu I did this with.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .