I'm currently trying to pickup the data of a HDD which PC is now dead (the M/B). I connected the HDD to my PC using an External IDE->USB Enclosure and can navigate thoughout some of the alien drive folders.

Aside, when I attempt to access some of the folders, like the ones in Documents and Settings\*, I always get the message that I need to go to the Security Tab.

Security Issue

The problem I'm having is because the ownership of the Document and Settings subfolders is undefined. Changing the ownership to MyPC\Administrators suffice to let me continue exploring the folder I just double-clicked. Then, I have to do it for all, and I mean for all the subsequent subfolders.


I would like to get a workaround as per setting the ownership all at once to all of this HDD's folders and subfolders, without being obliged to click [Continue], when I'm asked to, or going to the Security Tab to change the ownership manually for each single folder.


My PC:

  1. Microsoft Windows 7 Professional;

Alien HDD:

  1. Was using Windows XP.
  2. Currently connected through an external IDE/USB hard drive enclosure.


I need to retrieve important business files, since the PC this drive was installed on just died.


Is there a way to allow me to change all of the ownership of this external drive folders and subfolders so that I don't need to change it manually for each and every single folder again?

Please feel free to ask whatever question that may help you help me! I will be more than pleased to give the more accurate answer that I can with my basic knowledge as a system administrator (I'm a software developer).

Thanks for your kind help everyone! =)


This might not be the most direct solution, but you may want to try this. Linux doesn't obey NTFS permissions, it just loads the entire drive and lets you access whatever you want. You could boot off of a linux Live CD and use that to copy the files off.

Another approach would be to use the command line permissions editor to change all of the permissions. The program is icacls, and there is documentation for it on TechNet.

icacls "E:\path\to\folder\" /grant %USERNAME%:F /t

...will give full permissions to the user running the command to all folders and files in that directory, and all subdirectories. I tested it with a directory tree I had removed all read permissions from, and it worked on all the files in it. If you don't have ownership of the files, you may want to run

icacls "E:\path\to\folder\" /setowner %USERNAME% /t

to make yourself the owner of the files, then run the grant command above, once you have ownership. You may need to run these commands in an elevated command prompt.

  • And what are the instructions I should then type for copying to my Windows 7 drive? Is there no chance to scratch my Windows 7 installation? This is my development machine, so I don't want to mess with it - I'm sure you can understand that. =) Besides, if you say it is safe, I'm willing to give it a try, if there's no other doable solutions under Windows 7 directly. – Will Marcouiller Dec 2 '10 at 0:25
  • I just updated my answer with a solution which should work from Windows 7 directly. However, if you want to go ahead with the Linux method, use a distro like Ubuntu which has a GUI. You can copy-paste just the way you would in Windows. You won't damage your Windows installation as long as you don't go around deleting random things or telling it to install, rather than do a live boot. – nhinkle Dec 2 '10 at 0:29
  • +1 This has conducted to partially resolve my problem. Besides, some more sensible folders, yet the most important, still remain locked up. It says either D:\Documents and Settings\*: Access is denied or something like it doesn't know nor can it match the current user. – Will Marcouiller Dec 2 '10 at 0:51
  • What are the exact commands you've run, and the errors corresponding to them? – nhinkle Dec 2 '10 at 1:04
  • I must have done something wrong on the first place, because it just does the Access is denied message from now on. I tried both commands from a command prompt. Do you think I need to elevate my privileges running the command prompt as Administrator? (I'm going to try this...) – Will Marcouiller Dec 2 '10 at 1:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.