Why is the Console view on the vSphere client so slow? It's a real shame because it's a shame to have to establish an RDP session every time you work on one of the VMs because of the speed of the console (I saw a tool to right click and open an RDP session to a VM in vSphere Client/ESX but this was not reliable).

The Workstation console view is very smooth so I'd expect the vSphere Client console view to be very smooth.

  • I have the same problem, our servers aren't overburdened at all, I've found that it depends on the guest OS as well, usually server 2008r2 is pretty smooth, but 2003 x32 and x64 can be bad. – Peter Dec 2 '10 at 21:23
  • Really? I've found the exact opposite: Server 2k3 is nearly as fast as workstation, but 2k8 R2 has very noticeable lag. It's especially worse before the VMTools get installed. – Evan M. Dec 2 '10 at 22:24

I do not find the vSphere console to be slow. Maybe your system is over-burdened or you are experiencing network issues?

| improve this answer | |
  • Probably network issues, then. Even on low load (4-5 running VMs out of 30-40 VMs on a 32gb server), the console is quite slow. It's one NIC on the server, does that contribute to the speed? – GurdeepS Dec 2 '10 at 21:19
  • Same for me too, just as fast as 'workstation', of course it uses slightly odd ports iirc (902/903?) wonder if it slows down without them or just stops? – Chopper3 Dec 2 '10 at 21:26
  • I've also never had this problem. Did you install VMWare Tools? – JamesBarnett Dec 29 '10 at 1:18
  • Since nobody else mentioned it - Ensure you have turned off pointer shadow in Windows. This significantly speeds up the VI Client Console window. – Chris Thorpe Apr 17 '11 at 8:25

I've found that the VMware tools installation does not install the VMware SVGA drivers for Windows. Update the display driver manually it's under Program Files\common files\vmware\drivers\video. This made the console sessions much more responsive for me through vSphere.

| improve this answer | |

On Windows 2k8 I found I needed to change the hardware acceleration setting to high.

| improve this answer | |

Do you run the viclient under Vista / Win 7 / Server 2008 / Server 2008 R2 with activated aero / Glass effects? Disabling it worked wonders for us.

| improve this answer | |

You can try this below:

(Excerpt of content below was found at the webpage below https://wikileaks.org/ciav7p1/cms/page_17072154.html)

If the vSphere Web Client you are using is slow to open VMs in a console, the following explains how to speed it up. The main cause is due to the fact that the vCenter server is using a self-signed SSL cert. When a request is made, Windows tried to update it's own root certificates by connecting to a Microsoft server. You can turn off automatic root certificates update to stop this from occurring.

  1. In Windows, Click Start -> Run.
  2. Type gpedit.msc, and then click OK.
  3. Under Computer Configuration, select Administrative Templates -> System -> Internet Communication Management -> Internet Communication settings.
  4. Double-click "Turn off Automatic Root Certificates Update".
  5. Select "Enabled", and then click OK.
| improve this answer | |

It may also be DNS resolution. The vSphere client relies on the client host to resolve the ESXi host FQDN for MKS consoles.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.