I have a Linux server running Ubuntu Lucid that will eventually be used as an FTP server, with Samba installed so that the files on it can be accessed by machines on our Windows network. It works well from every machine but one, our Windows Server 2003 domain controller. Punching \\machinename into Explorer on the Win2k3 DC box causes the following error dialog box to instantly appear:

Windows cannot find '\\machinename'. Check the spelling and try again, or try searching for the item by clicking the Start button and then clicking Search.

Every other Windows machine on this network can browse the Ubuntu server no problems.

I don't think it's a DNS problem as the Windows box is able to connect to FTP on the Ubuntu server by name just fine, and the DNS server has both A and PTR records for the Ubuntu server.

I tried looking through the Event Viewer logs on the Windows machine and could not see any relevant events. There are two logs in /var/log/samba/ for the Windows machine, one with its name and the other with its IP address. They are both empty.

Other relevant details:

  • I'm almost a complete newb when it comes to Linux, so please assume I know nothing.
  • The Ubuntu server is not joined to any domain.
  • The DC does not have any trouble browsing the shares of other Windows servers. There are no other servers here running any *nix variety.
  • The same error appears when trying via IP (i.e. \\<ip>)

Any help with this would be greatly appreciated :)

I have increased the Samba logging level to try and sort out what's going on. In amongst the hundreds of lines I noticed that the DC is attempting to authenticate using the name of the account I'm logged in with, which I would expect, but when that fails it's not asking me for a different account like I would normally expect of Windows. I used the Stored Usernames and Passwords Control Panel applet to enter a username and password, which the DC appears to try using, but it still fails. I wonder if this problem could have something to do with the tighter security settings on the DC as compared to the other domain joined machines?

Update 2
I have now noticed that other 2003 machines that are not DCs have trouble accessing the server too - they produce the same error message. The small number of XP machines have no trouble, and the Vista/7 machines I've tried have no trouble, but servers running 2003 are all unable to connect to the Ubuntu server.


Community poke!

Depending on the encryption/authentication options you have selected, I'd guess it could be one of:

Compare these settings between working/nonworking machines, see what you get?

| improve this answer | |
  • Thanks for replying. We are still having this problem (the system is not used). I have previously checked both of these options, but I went and checked them again. One of the systems that has the problem has less restrictive options than one that doesn't... I changed them to be the same anyway, but it had no effect. – iltsra Mar 31 '11 at 6:48
  • Oh, I missed that it was a DC before. Think they have stronger requirements for SMB signing than regular boxen. Check the Microsoft Network Client: prefixed security options, and if not them, Domain Member: security options. – TristanK Mar 31 '11 at 8:12
  • Well what do you know. It was the require signing always setting; I changed that to Disabled on one of the other machines that has this problem (not the DC) and it works after a reboot. It was the first thing I suspected when I first started having this issue, and so I tried it then and got no results. The only thing I can think of is I probably forgot that I needed to reboot after changing the setting. D'oh! Anyway I'll try it on the DC later and see what happens. Thanks! – iltsra Apr 1 '11 at 3:59

what happens if you type


is Samba configured to listen on port 445? Win2K3 (and Vista/7) first try this port before falling back to port 139.

| improve this answer | |
  • Sorry, I forgot to say I already tried with the IP - it gives the same error as with the name. Port 445 is open. – iltsra Dec 6 '10 at 22:37

Sounds like a firewall problem on Ubuntu machine.

Please check, that 137-139/tcp,udp and 445/tcp are open in firewall.

| improve this answer | |

Can you check on your Ubuntu machine that nmbd service is running?

Type: sudo status nmbd

If you get a response like:

nmbd stop/waiting

then start the service with:

sudo services nmbd start

| improve this answer | |
  • Thanks Pavlos, I checked whether nmbd is running and it seems like it is. – iltsra Dec 6 '10 at 22:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.