During recovery Oracle writes the following error:

RMAN-06054: media recovery requesting unknown log: thread 1 seq 9 lowscn 4034762

I have used in mount mode this command:

change archivelog all crosscheck;
delete expired archivelog all;

Then restore and tried to recover again:But still RMAN-06054 error.Than I wrote:


It helped me to recover database...But after that when I do the backup and then recover the same error occurs and solution is the same... I wonder to solve this problem without SET UNTIL SEQUENCE 9 THREAD 1; maybe I should unregister this archive log from control file(I am using control file not catalog) Can you tell me how?

migrated from stackoverflow.com Dec 7 '10 at 13:37

This question came from our site for professional and enthusiast programmers.

  • How did you backup (and restore) the database? Which command did you use? Which operation did you perform at O/S level (copy files, ...)? – Benoit Dec 7 '10 at 14:26

If you want to "unregister" a backupset (or a part of it) from the control file, juste delete the files and use the "crosscheck" command at RMAN prompt:

rman> host rm -rf /what/ever/db/backup/*.arch
rman> crosscheck archivelog all;

Have a look at the backup and recovery books in Oracle Documentation Library: http://www.oracle.com/pls/db102/portal.portal_db?selected=3#index-BAC (this is for 10Gr2)


this is normal from 10g and up - the control file is requesting what it assumes to be the next archive log seq. Once the restore completes, and the recover applies at least one archivelog, I wouldn't worry about it. I would just type:

sql 'alter database open resetlogs';

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.