I guess the easy answer to my question is 'Something doesn't have the correct permissions'. =P. I read Backup Exec b2d NAS, but that didn't really answer my question.

I have poked around the Admin guide and google trying to nut this out, but I'm not really getting anywhere very fast and I am loath to call Symantec support if I can avoid it.

The basic setup:

Cisco NSS324

Windows Server 2003 - SP2

Symantec Backup Exec 10D

I want to create a B2D job to the NAS, and have used the UNC path \\<NAS DEVICE NAME>\<TOP LEVEL SHARE>\<BACKUP FOLDER>\. However as soon as I hit 'OK' an "Access is Denied" error pops up.

The NAS has properly joined the network domain and I have given the 'veritas' AD user full read/write access to my NAS share via the Cisco Web Interface and added the 'veritas' user to the AD 'Backup Operators' group (though this group does not appear in the Web Interface as a domain group I can give access to, leading me to suspect this step might be moot) and the funny thing is I can actually browse to the folder within BE10D!

I'm obviously missing something pretty basic here,

I'm just not sure what. Can anyone give me a pointer?



Ah, damn it. I realised after posting yesterday that I had connected to a local drive (Got B:\ somehow confused with Z:\), not the NAS. Therefore I am a giant dumbass and have not solved this yet.

I am still getting an "Access Denied" message when using the UNC path, after adding permissions for the 'veritas' user on the NAS Share, the folder I am backing up and adding the user to the "Backup Operators" group.

I have tried mapping the IT_Admin share on the NAS to Z:\ and used the path Z:\Backup\ which gives an error saying "The system cannot find the path specified". If I add "\\" in front of the drive letter the error changes to "The network path was not found". I’m pretty sure using the mapped path wouldn’t work anyway from I read over at http://www.symantec.com/connect/forums/bacup-network-drive-backup-exec-10d.

The device name is "NSS324", the top level share I created is "IT_Admin", I have created a folder at the root of the share called "Backup". I feel pretty confident the UNC path of \\NSS324\IT_Admin\Backup\ is correct. Could someone higher level possbily be able to confirm?

I don't want sound like I am asking to be spoon fed, but really not sure what else I can give the user permissions to, in order to get this to work. Anyone feel like throwing in their 2c?

  • What are you trying to back up? Files, SQL Databases, Exchange? – Ben Pilbrow Dec 7 '10 at 22:20
  • 1
    Is the <Top Level Share> a share you created on the NAS or is it a default share on the NAS? If it's a default share try creating a share specifically for the backups and try that. – joeqwerty Dec 7 '10 at 23:59
  • @Ben, I'm backing a heap of different stuff, Offce14 docs, Access MDB files, AutoCAD files, pngs, jpgs, raws, pdfs. @joeqwerty. I created a specific share for the backup on my NAS. Thanks for your help anyway guys, definitely put me in a different frame of mind to figure out where I went wrong. – Markovs Dec 8 '10 at 0:30
  • I was going to suggest checking permissions on what you were trying to back up - I was just trying to establish what it was, as the procedure is slightly different for each. Glad you got it sorted - please mark your answer as the accepted answer (with the green tick) so it doesn't get randomly bumped at some point in the future. – Ben Pilbrow Dec 8 '10 at 0:36
  • @Ben, yeah I had a feeling that might have been where you were headed... thanks! ;D Also thanks for the heads up on marking my answer. Done and dusted! Ah, its saying I need to wait 48hrs before I can mark my own answer as correct. D'oh! – Markovs Dec 8 '10 at 0:48

Try logging onto a computer as your Veritas user and confirm you are in fact able to browse to the data you're trying to back up, and try copying something from the network share to the computer. Also check you can browse to the NAS share and create files on that.

On your Backup Exec Media Server, try and browse to the root of \\NSS324. I don't know about this particular NAS, but if it's a Linux based NAS, I have seen those sometimes either not register themselves in DNS properly (or at all) or they don't consistently answer to their assigned name. If that doesn't work, you might want to try a fully qualified name (i.e \\NSS324.corp.acme-widgets.com (obviously replace that with your actual FQDN)).

In your B2D media, there is no need to map the share on the NAS to a Windows drive letter - Backup Exec will be perfectly happy with simply \\NSS324\IT_Admin\Backup.

I've experienced some idiocy from the Backup Exec interface before, where it claimed the user I has specified as the backup user didn't have enough permission (when it really did). If I ran the job manually, it backed up everything and the job completed successfully (confirmed with a restore).

I've also found any errors in the Backup Exec job log are more useful than the error messages you get when setting up a job. It might be worth setting up the job and ignoring any permission errors you get and run it anyway so you can interrogate the job log. Any errors or warnings in the job log generally point to a Symantec KB article, which admittedly isn't always helpful, but might prompt you to think about something you maybe overlooked.

  • Awesome answer, thanks Ben! I'll give all of that a shot and update the thread with my results. – Markovs Dec 9 '10 at 22:26
  • AH HAH! I can't map to the NAS Share via its UNC path in Windows either. Auth window pops up and nothing I enter lets me in. If I use the IP instead of the device name I can get into share no probs. Will look in to this further and update. One step closer! :D – Markovs Dec 10 '10 at 1:03

GAH! I didn't give the 'veritas' user proper permissions to access the folder I wanted to backup via explorer.exe...


Sorry for wasting everyone's time!! >.<


Intrestingly, I still wasn't able to use the UNC path to get this to work (possible that I have not entered the path correctly). I have mapped the share as B:\ on the WinServer, and after giving the veritas user proper permissions to access this, I created a "Backup" folder at the root level of the share and browsed to it via BE10D, clicked ok and everything was sweet. Still haven't tried actually doing a backup/restore to/from this folder yet, will update if anything goes awry.

EDIT # 2

Finally figured this one out (though I kinda cheated as I had some external help from someone helping us set up a BES yesterday).

I had the NAS Share mapped by is IP on my Win Server (\x.x.x.x\Share Name\Backup) and used my admin AD credentials to login to the share. We disconnected this drive and remapped it using its UNC path. The only way to logon to the share now was to use the admin login for the NAS, so when the windows auth window popped up for my access to the share I used "device name\admin" and its associated password.

I was now logged into the share via its UNC path in Windows. Reopened BE10D and reattempted to create a B2D to the NAS share it worked like a charm! No access denied errors or anything!

I’ve done a backup and restore to the NAS Share, both of which worked and this question is now solved. Yay! :D Thanks again to everyone for your help!

  • +1. Not a waste of time from my perspective. Sometimes it's the simple things and sometimes it's not, and sometimes you just need some outside nudging to get you going again... – joeqwerty Dec 8 '10 at 2:20
  • Plus it's good Google fodder for anyone else having similar problems. – Ben Pilbrow Dec 8 '10 at 14:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.