I'm trying to adjust Message Queuing properties (specifically, message storage limits) via Computer Management on my machine. It fails with the following message:

The properties of cannot be set.
Error: Access is denied.

I am logged in with an account that is part of the local Administrators group. I can perform all other administrative tasks I have tried. What could be preventing me from changing these settings?

Platform: Windows Vista Business SP2 (x64)


Putting this here for posterity ;)

Background: For as long as I’ve been using Windows 2008 R2, I have not been able to change the Message Queuing configuration settings (such as storage limits, storage locations, security, etc.) or access the System Queues (Journal messages, Dead-letter messages, Transactional dead-letter messages); all attempts at doing any of these things resulted in a cryptic “Access is denied” error. Whenever I needed to install Message Queuing on a server in our environment, I used Server Manager to install the Message Queuing Feature.

Solution(?): On a whim, rather than install the Message Queuing Feature, I instead choose to add the “Application Server” Role. Adding this role automatically selected and installed the Message Queuing Feature, though it only enabled the Message Queuing Server, not Directory Service Integration and Message Queuing Triggers.

I am now able to re-configure Message Queuing settings, as well as access and perform actions on the system queues.

  • Did you find any other fix to that problem? This solutions is hard in case when you have a lot of configured queues. – Restuta Mar 17 '12 at 0:57
  • @Restuta, unfortunately no, we didn't find any other solution. – Patrick Cuff Mar 20 '12 at 18:09

This blog may also be useful: http://blog.aggregatedintelligence.com/2012/03/msmqsecurity-descriptor-cannot-be-set.html

Basically, it says that in order to be able to change the settings of a queue, your account must be set as an owner of the queue and it explains how to do so.

It worked for me.

  • 1
    The manual method at that site fixed my problems. This really should be the answer because the selected one requires a reinstall. – user2426679 Dec 23 '15 at 17:16

So what are the security settings for Message Queuing on your machine? If the settings are open enough then it maybe a User Access Control issue where Computer Management is not being raised to administrator level even though you are logged in as a local admin.

Cheers John Breakwell

  • I am running Computer Management as Administrator. (choosing "Run as Administrator" – Restuta Mar 20 '12 at 21:54

I had the same problem and found this useful:

  1. Go to the server which host the MSMQ
  2. Click Start > Run then Regedit
  3. Navigate to HKLM\Software\Microsoft\MSMQ\Parameters\
  4. you will see a Binary Type ‘REG_DWORD’ named as Workgroup.
  5. The Data for that should be 0×00000000 (0)
  6. Doubleclick on that DWORD and change the value to 1. Leave everything else as default
  7. Close Regedit
  8. Go to services then restart MSMQ service.
  9. Right click properties on Message Queuing. You should be able to see more tabs and the error is gone.
  • hmm... doesn't work for me... – PierrOz Jan 5 '15 at 11:46

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.