I am trying to ssh into my EC2 instance, and get the following ssh verbose output. THe identity file is in a pem format, which is X.509, i think. I dont know the login name, or I could have tried with the -l flag. Prior to this, I only recieved a file permission error, because the file had improper permissions, which i changed to 600, and the directory containing the key to 700. The keys aren't in the ~/.ssh folder, but in ~aws-kes/aws-keys.pem

I run this command:

$ ssh -v -i aws-keys/aws-keys.pem ec2...ompute.amazonaws.com

and I get the following output:

OpenSSH_5.3p1 Debian-3ubuntu4, OpenSSL 0.9.8k 25 Mar 2009
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug1: Connecting to ec2...ompute.amazonaws.com [] port 22.
debug1: Connection established.
debug1: identity file aws-keys/aws-keys.pem type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_5.3
debug1: match: OpenSSH_5.3 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_5.3p1 Debian-3ubuntu4
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-ctr hmac-md5 none
debug1: kex: client->server aes128-ctr hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Host 'ec2...ompute.amazonaws.com' is known and matches the RSA host key.
debug1: Found key in /home/wissen16/.ssh/known_hosts:10
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey
debug1: Next authentication method: publickey
debug1: Offering public key: wissen16@wissen16
debug1: Authentications that can continue: publickey
debug1: Trying private key: aws-keys/aws-keys.pem
debug1: read PEM private key done: type RSA
debug1: Authentications that can continue: publickey
debug1: No more authentication methods to try.
Permission denied (publickey).

EDIT: I read a few of the possible similar questions, and they didn't help me :(


Well you need to supply the user name (login) AND the private key for the authentication to succeed.

Otherwise it tries to log you on whith your current (local) username. So if you don't know which username goes with your key, you won't be able to login using ssh.

  • i have a pem file. I converted it into a ssh-key and still couldnt login. – theTuxRacer Dec 10 '10 at 12:01
  • Oddly, I can ssh in with my key.pem and get connected with our without a username supplied. I'm beginning to think AWS is a bit nutty. There must be 50 SSH EC2 questions... – Chris K Jun 5 '12 at 19:02

I created a new Ubuntu Instance from the community AMIs. I was able to ssh into the instance, using the same command. Thanks all, for helping out.


#ssh -v -i id_YWDRajat ec2-user@ above ref is working fine for me :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.