Attempting to install SQL Server 2008 R2, Standard, Developer Edition, and/or Express on Windows 7 Enterprise, I keep getting 'Access is denied' at the very end of the installation. Contents of log:

Configuration error code: 0xDC80C325

Configuration error description: Access is denied

I've tried these suggestions with no success :

SQL Server 2008 Access Denied

SQL 2008 install on Windows Server 2008 Permission Denied errors r-2008-permission-denied-errors


Even our system administrator logging in as the local machine administrator is unable to complete the installation or give rights to/change the local debug policy (as suggested in the above links).

Thanks for any information.


Here is a solution for this.

This failure often is caused by a system or domain policy removing the SeDebugPrivelege security privilege from the administrator account running setup. Verify that the account running has this privilege.

The AccessChk tool will print all privleges for an account (http://technet.microsoft.com/en-us/sysinternals/bb664922.aspx) by running: accesschk.exe -a \ *

Alternatively, we can check this through your group policy editor as mentioned below:

Open Group Policy... Start | Run | Type: gpedit.msc | OK | Navigate to Computer Configuration\Windows Settings\Security Settings\Local Policies\User Rights Assignment\Debug programs

The account through which we are trying to run the setup should be here ( besides the local admin on that machine). I included that here, restarted the server ( this is mandatory, gpupdate /force will not work) and ran the setup and it was successful this time.

SQL Server 2008 setup needs this privilege to start up the SQL Server process and listen to an event that signals back to setup that SQL Server successfully started.

  • 1
    Already suggested in the links I included in the question. The 'Debug program Properties' dialog box/Local Security Settings tab is empty and the button to 'Add User or Group...' is disabled. Our sysadmin has no idea what is needed to fix the issue. Hence the question to serverfault.com – KevinRF Dec 14 '10 at 14:15
  • Another sysadmin 'discovered' the group policy being pushed down preventing the installation. Once the debug permission was added, tada...installation worked like a champ. – KevinRF Dec 20 '10 at 13:34
  • This worked for me, too! – James Sun Aug 18 '15 at 18:20

Please use the utility from the below URL to investigate the issue:


  • Thank you for the quick response. The results are (for my account) SeBackupPrivilege and SeSecurityPrivilege. Executing the command on the admin account doesn't have the SeDebugPrivilege and the ability to set the option is grayed out. – KevinRF Dec 13 '10 at 19:51
  • Can you please provide me the Exact error from Eventvwr – Gaurav Singh Dec 13 '10 at 20:11
  • There isn't any meaningful data in the event viewer other than where the install logged the error details file. The file is over 21,000 lines. The first error: Configuration action failed for feature SQL_Engine_Core_Inst during timing ConfigRC and scenario ConfigRC. Access is denied – KevinRF Dec 13 '10 at 21:14
  • Open Group Policy... Start | Run | Type: gpedit.msc | OK | Navigate to Computer Configuration\Windows Settings\Security Settings\Local Policies\User Rights Assignment\Debug programs – Gaurav Singh Dec 13 '10 at 21:28
  • an you verify the permissions in regedit on the branches mentioned above? They are: HKEY_LOCAL_MACHINE\Software\Microsoft\Microsoft SQL Server\ HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\Curr entVersion\Uninstall\ HKEY_LOCAL_MACHINE\Software\Microsoft\MSSQLServer\ – Gaurav Singh Dec 13 '10 at 21:28

Do you have User Access Control turned on? If UAC is on then even members of the Administrators group don't have the same access as the Administrator account. You have to either turn UAC off or log on as Administrator.

  • As suggested in the links I included in the question, UAC is turned off and the set up is executed as an administrator. – KevinRF Dec 14 '10 at 13:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.