I just purchased a refurbished DELL PowerEdge 1850. When I first turn it on, it automatically goes to the Intel Boot Agent to look for a PXE boot. I want to install Ubuntu 10 Server from the CD and not from a PXE boot, so when I disable booting from each of the network cards in the BIOS (and still leave the CD and hard drive boot options enabled), the system says does not seem to read the CD-ROM and says "No boot device available."

I have also tried inserting a USB stick with Ubuntu on it, but it does not seem to be read. The computer does recognize the USB keyboard.

I do have the correct architecture of Ubuntu (amd64) for this computer (Intel Xeon).

The CD-ROM does have power (it spins when you insert a CD), and both the RAID and SCSI controllers work (the two hard drives spin up when the computer boots).

Is there some option I need to enable in order for the computer to do something other than PXE boot/nothing?

The computer has BIOS version A06.

  • Is the CD rom set as the first boot device? i.e. the top of the list? – user68387 Feb 15 '11 at 20:02

Swap out a known working CD drive and test this CD drive in another machine.

Reseat all cables to the CD drive.

Test booting from the CD media in another machine, and/or burn another CD and see if that works.

Also, F12 on boot has an option to choose the boot method but won't help if the drive and/or CD media are faulty.

| improve this answer | |

Try using an external DVD/CDROM drive with it. I have had it boot of those even when they won't boot off a USB stick.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.