Very strange issue here - I simply cannot open the IIS 7 manager by choosing it directly.

My OS is Windows 7, and as such, I can see it's opened on the Start Menu aswell as a preview of the window itself when I hover over it. I cannot however, see the actual window itself. I can click it on the task bar (it does 'start'), and it doesn't report any errors - it's as though the window will not maximise...

Even more strangely, I can open the IIS manager by starting the MMC and adding the IIS Manager snap in - which works fine...

Any thoughts?



I wonder if it's on a "2nd monitor", what happens if you right click on the taskbar icon, and select move, and then move it to your main monitor? Does that bring it back?

  • Hey, thanks for the suggestion, but this is definetely not the problem :( – Dave Dec 14 '10 at 12:51
  • 1
    Can you telnet to the host/port that it's listening on- i.e. is it really listening? (also, have you tried a reboot?) – AliGibbs Dec 14 '10 at 12:56
  • I've tried a reboot and the IIS process itself is still working. Following your suggestiong though, I had a closer look - howtogeek.com/howto/windows/… - this sorted it. Thanks for the suggestion problem solved. Boy do I feel stupid :) – Dave Dec 14 '10 at 12:59
  • We have all done it- glad your problem is solved :) – AliGibbs Dec 15 '10 at 9:41
  • 5
    By the way, if you run Inetmgr.exe /reset it will run and reset its preferences which includes the starting position which would also "fix" the problem – Carlos Aguilar Mares Dec 16 '10 at 6:58

After just experiencing this problem myself the solution I found in the end was to open task-manager shut down explorer.exe in the Processes tab, maximize IIS in the Applications tab and then run explorer.exe as a new task.

I am aware of the age of this thread however I just had this happen to me on a machine running Server 2008 R2 and this post was the only related article I could find so I'm hoping my contribution will help a future user in need.

  • How do you "run explorer.exe as a new task"? – reggaeguitar Dec 31 '15 at 16:48
  • I figured it out, go to File -> Run in Task Manager, type in "explorer" and hit enter – reggaeguitar Dec 31 '15 at 16:51

Do you have MOSS installed? If so, check this. KB Article

  • Thanks for the suggestion Chris - I tried working through that but it hasn't had any effect so I don't think this is the issue :( – Dave Dec 14 '10 at 12:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.