I am having a continuing issue with Linux regarding the setup of FTP permissions. I am using vsftp and fedora 13, I have two users userA and userB I have set the folder permissions to ftp:ftp and 644. Both userA and userB are members of the ftp group yet when I create a folder and try to ftp it up I get a permission denied error. If I set the folder to userA:userA and 644 then userA can ftp anything and create anything but userB cannot. Also note that I have the vsftpd.conf configured to allow write and I am not using the chroot_list.

My question is what should be the correct folder permission settings for FTP to allow multiple users to create files/folders within the ftp directory?


1 Answer 1


Firstly I would make sure that the user was created by the ftp user itself just to eliminate any variables. if this is the case then try making sure that you have permission to view the directory itself:

 chgrp -R ftp <directory>

and then verifying with ls -l to make sure the group really is ftp

if you still have problems I would highly recommend using a web administration interface such as Webmin, as it automatically installs common servers such as http, mail, ftp, squid etc... and sets up their respective directories and users with no hassle.

Hope that helps RayQuang

  • Thanks this worked but only when I gave the folder 777 rights?
    – aHunter
    Dec 14, 2010 at 13:30
  • I'm missing something...if you give the folder 777 rights, that gives everyone full access regardless of membership or access. If you give 777 then chgrp shouldn't matter anyway. But it does open a potential security hazard to that directory, unless it's contained or you are comfortable with the risk. Dec 14, 2010 at 14:00
  • I suppose if this is for your home server that you will be using for your personal files then it should be ok :) If this is a production server I would recommend using something like webmin or just getting some books on setting up servers, there are slso some good guides on the ubuntu wiki and TLDP.
    – RayQuang
    Dec 14, 2010 at 14:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.