I have 3 Linksys SR2024 switches which are basically non-managed 24 port Gbit + 2 miniGBIC.

I now had to add another switch to the network, and my provider didn't have the SR2024 switch anymore, so I got the Cisco SLM2024 which was a bit more expensive. It's pretty much the same thing but with management (that I don't need).

So I've connected the SLM2024 to a SR2024 via Cat6 cable, and for some strange reason, I get no link.

If I connect any machine with a Gbit NIC to both switches, it links with 1Gbit autonegotiated. If I connect the SLM2024 to a non-Gbit switch (I have a cheap 4port ASUS switch), it will link just fine on 100Mbit full duplex.

Since the SLM2024 has management, I've tried to see if something is misconfigured on it's side, but it's not, it advertises 1Gbit and lower. (hence the machines connecting succesfully at 1Gbit).

Since the SR2024 that I'm trying to connect it to also connects successfully with another SR2024 and other Gbit machines, it means that it advertises Gbit too.

But for some reason when I link the SR2024 to the SLM2024 I get no link.

Please note that I've properly tested the wire.

Does anyone have any idea what's wrong?

  • How are the ports configured? Post your conf? Are the ports configured as trunk? Any debugs? How about the cable. Is it a straight cable or cross-over? – Ablue Dec 29 '10 at 2:34

The switches may require a GigE crossover which requires all four pair crossed not just two pair as a Fast Ethernet crossover cable has. (Adding as answer per original poster's comment above)


Check if the SLM has an option in port configuration about "mdi negociation".

Basic switches are often "auto mdi-x", so that they can cross the cable automatically.

Try with a crossover cable, the link should come up.

  • I've checked that, it's on auto, so it should work. Yet it doesn't. – Prody Dec 15 '10 at 1:22
  • have you tried using the a cross over cable as suggested as well? – Rex Dec 22 '10 at 15:55
  • 3
    Keep in mind a GigE copper crossover cable has to have all four pairs crossed. – Thomas G Dec 22 '10 at 20:51
  • yep, tried it :( – Prody Dec 24 '10 at 22:54
  • @ThomasG that was it, thanks. Please post an answer with it so I can give you credit. – Prody Jan 4 '11 at 12:03

I know it's silly, but have you tried multiple different ports on both switches in case one port is configured wrong and/or broken?

Have you tried resetting the SLM2024 to factory settings? Maybe some kind of security setting was accidentally switched on before you received the switch.

When you are testing, have you unplugged every other device on the SR2024 and are just trying to plug SR2024 to SLM2024 with no other devices connected?

Lastly, even though it shows no link, have you tried setting up something like: computer1 <---> SLM2024 <---> SR2024 <---> computer2 just to see if computer1 and computer2 can see each other?


A couple of issues Ive seen with the SLM2024 -

Factory firmware was a pain. I've installed about a half dozen of these and was forced to update the firmware every time to prevent weird network lockups.

I think that only specific ports will let you uplink on this switch but I cant remember which, it might be just port 24.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.