In Windows 2003 when i run plink without arguments, it says "unable to open connection: host does not exist"

(And of course when it is run with arguments)

What can be the cause? I am becoming crazy


If you have a hostname or IP Address defined in the default settings for putty then plink will try and connect to that address and use the default settings. If there is no hostname or IP address defined then plink will use the command line.

| improve this answer | |

I solved by deleting HKEY_CURRENT_USER\Software\SimonTatham

(by doing plink -v i saw it was connecting to a dummy server... strange - i never used putty/plink on this server, maybe it is a leftover by another program)

| improve this answer | |
  • Wow, thank you very much, that answer just solved my problem. The -v switch showed me that even though I was asking plink to connect to, it was actually connecting to, an IP adress that I'd set up and was using in putty.. Deleting the registry entries allowed me to connect to the proper server, and now everything's working fine! – user77406 Apr 6 '11 at 17:05

To add to the previous comment... I found that using putty to authenticate a session on the machine in question creates the sshHostKeys registrations in the registry and plink can then use that for it's authenticating. This works quite well and a simple statement like:

plink -ssh my.hostname.com

will automatically get you to a user prompt on the host machine. No fuss! worked for me!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.