I have a Netgear fvx538. Last night, I found that all the lights were on for IP connections to machines, but the router could not do normal functions: dish out addresses by DHCP, allow connection to internet, etc.

I am not sure what to do with this. Possible options I have not tried:

  1. Use second port for WLAN source

  2. Reset to factory defaults

  3. Connect via RS-232 connection (no idea how to proceed with this)

And how can I figure out what actually happened?

Yes, I've tried power-cycling it. Same result: all connection lights on, no machine given an IP address.

Later: it looks like using the second port is the obvious first step:

"The FVX538 has two broadband WAN ports, WAN1 and WAN2, each capable of operating independently at speeds of either 10 Mbps or 100 Mbps. The two WAN ports let you connect a second broadband Internet line that can be configured on a mutually-exclusive basis to:

• Provide backup and rollover if one line is inoperable, ensuring you are never disconnected."

  • Did you power-cycle it? If so, is it working now? – EEAA Dec 15 '10 at 16:18

I've seen this problem before with the FVX538. In the end, we disabled DHCPd on it, and used a Cisco 2621XM as the DHCP server for the network.
Basically, we came to the conclusion that the Netgear device was running out of memory. You can power-cycle it, and it might work again for a while, but you might then find yourself rebooting the device every few days. We had 3 of the devices, and they all exhibited the same problem eventually. Which is why we ditched them and replaced the DHCP bit with a router (and the Dual-WAN bit too, eventually)

  • Okay, but I can't log on to the router: not with a direct connection, not with HTTP. First thing is to get onto the box. And I am not sure why memory consumption for DHCP would be a problem: there are maybe 6 machines on the network. And power-cycling the box does not eliminate the problem (as you would expect -- power-cycling would free up memory). – user28266 Dec 15 '10 at 17:49
  • I've had it for two or three years without a problem. Based on my experience, I wouldn't sign up for a blanket condemnation of the hardware. – user28266 Dec 15 '10 at 18:48
  • 1
    Ah, just getting into watchdog time then. How long out of warranty is it? ;) – Tom O'Connor Dec 15 '10 at 19:10
  • 1
    Got to agree with Tom. Netgear are cheap for a reason and I saw another one of their boxes (different model) do the exact same thing as its way of telling you it was time to buy a new one. Now if you're just talking about very small office use and that's all you can afford then I won't knock it (but I'd still personally shop elsewhere if I could). You're never going to get great results out of a netgear anything. – Rob Moir Dec 15 '10 at 19:47

I'd try factory defaults as a last option. First, you'd connect via RS-232 and use something like PuTTY to send and receive commands. You'll probably need to consult some documentation on your device to see exactly how to connect and what serial port settings you need. Baud rate, stop bits, etc.

  • PuTTY requires you to attach to a machine by IP address, no? My linux machines have no eth0 addresses (as shown by ifconfig) and they cannot ping any machine. They are not on the network. – user28266 Dec 15 '10 at 16:52
  • 1
    No, you do not need an IP address if you're using the RS-232 (serial) cable. Just open up putty, select the Serial option under the host name, and click Open (assuming you only have one COM port on the PC you're using). – Dan Dec 15 '10 at 16:56
  • Hmmm. Sounds like I am going to have to track down an RS-232 cable. I haven't needed one since 1992. – user28266 Dec 15 '10 at 17:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.