After updating my Wordpress site running on IIS7 to version 3.0.3 I tried updating the theme (LightWord) to the latest version. The theme auto upgrade feature failed so I logged into my server and tried to access the directory of the theme via the file system(C:\websites\wordpress_root\wp-content\themes\lightword). To my surprise I was told I did not have access to the directory. I tried viewing the ACL list for the theme folder but again was denied access. I access the Windows 2008 machine (which is actually a VPS) via RDP but I log in as an administrator. Shouldn't I have I have access to ALL files on the server? Has anyone else run into this issue?


It looks like even the Administrators group was removed from that folder. It's rare for an app to remove that, but it does occur. The LightWord theme installer must have a bug in it.

You can get it back again by taking ownership of the folder. You can do that from the same security tab as you update the permission. Take ownership, save out, and then add the administrators group back again.

| improve this answer | |
  • Thanks for the answer. I tried doing just that, taking back ownership, however I got the access denied message. I even tried to use "takeown" from the command line (running as administrator) but I still received an access denied message. I decided to disable UAC and then rebooted the VPS. After the reboot I found the entire lightword theme directory was gone. very strange. – webworm Dec 17 '10 at 21:43
  • Possibly something was stuck in the installer and needed to complete, so the reboot cleared it up. In regards to the permissions, first you take ownership, then you still need to grant your user (or Administrators) NTFS permissions. Taking ownership just allows you to grant the NTFS permissions. In any case, it sounds like the folder has been cleaned up now. – Scott Forsyth - MVP Dec 17 '10 at 22:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.