We have a Windows 2003 server with client XP and Windows 7, all our printers are installed on the server and a login script installed the printers to our client when they login.
It's working fine with XP pro and now we have Windows 7, a pop-up appears saying the driver need to be downloaded from the server and only proceed if you trust the server. Since the users have only power user rights they can't install it. I have lowered the users account settings to low already.

I search and came across some suggestion such as:




saying I need to set the GPO to enable point and print restriction which I can't even find under the computer configuration settings. Maybe they were referring to Windows 2008 server.

I have called Xerox also about it and they said because there drivers have not been certified by Microsoft yet so that is why it pops up with this message.

I did managed to get around it by installing the driver on the local machine using admin rights and then delete it and the script will install without any prompt, but we have hundreds of machines, anybody can help me with this, much appreciated.

I just want to install the driver on Windows 7 machine using a script.



Please see the following link, I believe you have the same issue that this resolves.



I see you have found point and print. The way to enable point and print is to obtain the ADM files and import them onto your server.


Have you tried the below from one of your links? I have just tested it on my test network successfully.

You have to set the GPO for Point and Print restrictions and Deploy the printers to the users using Group Policy . This will get rid of that admin prompt for non-admins when installing printers on Windows 7.


To deploy printers to users or computers by using Group Policy 1. Open Print Management. 2. In the left pane, click Print Servers, click the applicable print server, and click Printers. 3. In the center pane, right-click the applicable printer, and then click Deploy with Group Policy. 4. In the Deploy with Group Policy dialog box, click Browse, and then choose or create a new GPO for storing the printer connections. 5. Click OK. 6. Specify whether to deploy the printer connections to users, or to computers: To deploy to groups of computers so that all users of the computers can access the printers, select the The computers that this GPO applies to (per machine) check box.

To deploy to groups of users so that the users can access the printers from any computer they log onto, select the The users that this GPO applies to (per user) check box.

  1. Click Add.
  2. Repeat steps 3 through 6 to add the printer connection setting to another GPO, if necessary.
  3. Click OK.
  • The link you provided seems to be for Windows 2008 server, we have a windows 2003 server, so the point and print GPO is not in the computer configuration, you said I need an adm file to import to the server to get this, where can I download this, is it once installed I can follow the intruction for windows 2008 server and it will work? Thanks – user63434 Dec 19 '10 at 17:32

James has it right. Deploy through Group Policy and never look back.

I for one prefer using Group Policy Preferences to deploy printers, as the management is a bit easier and can be done entirely from Group Policy Management, without requiring the Print Management MMC to do the printer portion. Whichever way works for you, though.

If you're having permission issues specifically, it could be that the clients don't have permissions to add network print drivers because of an improper Group Policy (or local registry) problem. Take a look here (specifically under "Trusted Path" and the "Devices: Prevent users from installing printer drivers" section).

  • +1 - Also a very valid resource! – JamesK Dec 17 '10 at 17:16
  • We don't have the print management MMC for windows 2003 server, I use a vbs script to match the computer name and install the printers when our users logon using windows XP pro, now we have some windows 7 machines there security seems to not allow the printer to install, I have added the domain users to the local power users group so it's the same as the xp. – user63434 Dec 19 '10 at 17:35
  • You need to configure these preferences from a Windows 7 machine, rather than XP or Server 2003. – scampbell Dec 20 '10 at 16:19
  • But we have hundred machines, I need to do it using GPO, any ideas? – user63434 Dec 20 '10 at 16:45

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.