I have 2008 r2 64bit server that is stuck on installing updates. It shows message "Please do not power off or unplug your machine. Installing 57 of 61.." This message is shown for 3 hours now. I was trying to connect to this server using mmc.

runas /user:AdministratorAccountName@ComputerName "mmc %windir%\system32\compmgmt.msc"

RUNAS ERROR: Unable to run - mmc C:\Windows\system32\compmgmt.msc 1311: There are currently no logon servers available to service the logon request.

What else can I do?

Update: Remote Desktop does not work. It just disappear after entering username and password from Win7-64 computer

Update: I have disconected server. Now Server Manager in Roles Summary shows message "Unexpected error refreshing Server Manager: The remote procedure call failed." Event log shows

Could not discover the state of the system. An unexpected exception was found:
System.Runtime.InteropServices.COMException (0x800706BE): The remote procedure call failed. (Exception from HRESULT: 0x800706BE)
   at System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32 errorCode, IntPtr errorInfo)
   at Microsoft.Windows.ServerManager.ComponentInstaller.ThrowHResult(Int32 hr)
   at Microsoft.Windows.ServerManager.ComponentInstaller.CreateSessionAndPackage(IntPtr& session, IntPtr& package)
   at Microsoft.Windows.ServerManager.ComponentInstaller.InitializeUpdateInfo()
   at Microsoft.Windows.ServerManager.ComponentInstaller.Initialize()
   at Microsoft.Windows.ServerManager.Common.Provider.RefreshDiscovery()
   at Microsoft.Windows.ServerManager.LocalResult.PerformDiscovery()
   at Microsoft.Windows.ServerManager.ServerManagerModel.CreateLocalResult(RefreshType refreshType)
   at Microsoft.Windows.ServerManager.ServerManagerModel.InternalRefreshModelResult(Object state)

Update: Manual update hangs on (Installing update 58 of 62...) Security Update for Windows Server 2008 R2 x64 Edition (KB979309)

Update: It could be an issue with that admin user was renamed

Update: I have have restored system from last snapshot

1 Answer 1


I have a similar problem! Very frustrating when the roles just says "error". Anyway I did some research into what the problem could be and came up short but hopefully my findings will help you. I found this tool from Microsoft and apparently it fixed the problem for quite a few other people. It didn't work for me and hung for hours checking my system for updates. But it looks like your issue differs slightly from mine since yours never made it past the initial install, so it might work for you. Sadly I have gotten to the point that I am going out to our data center next weekend to reinstall, thankfully it is just one of many remote desktop servers we have.

  • Thanks for this fix. it worked for me. i started installing the updates and the VM crashed. i was unable to get beyond update 7 of 56. with this tool. it fixed it and now the updates are completed. Hope i can now install any application that is written in x64, like SQL 2008 and the VC++ 2008
    – user80437
    May 4, 2011 at 22:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .