0

trying to install memcached with "yum install memcached" and i'm getting all these errors which I have no idea how to solve.

Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package memcached.x86_64 0:1.4.5-1.el5.rf set to be updated
--> Processing Dependency: perl(AnyEvent) for package: memcached
--> Processing Dependency: perl(AnyEvent::Socket) for package: memcached
--> Processing Dependency: perl(AnyEvent::Handle) for package: memcached
--> Processing Dependency: perl(YAML) for package: memcached
--> Processing Dependency: perl(Term::ReadKey) for package: memcached
--> Processing Dependency: libevent-1.1a.so.1()(64bit) for package: memcached
--> Running transaction check
---> Package compat-libevent-11a.x86_64 0:3.2.1-1.el5.rf set to be updated
---> Package memcached.x86_64 0:1.4.5-1.el5.rf set to be updated
--> Processing Dependency: perl(AnyEvent) for package: memcached
--> Processing Dependency: perl(AnyEvent::Socket) for package: memcached
--> Processing Dependency: perl(AnyEvent::Handle) for package: memcached
--> Processing Dependency: perl(YAML) for package: memcached
--> Processing Dependency: perl(Term::ReadKey) for package: memcached
--> Finished Dependency Resolution
memcached-1.4.5-1.el5.rf.x86_64 from rpmforge has depsolving problems
  --> Missing Dependency: perl(AnyEvent::Socket) is needed by package memcached-1.4.5-1.el5.rf.x86_64 (rpmforge)
memcached-1.4.5-1.el5.rf.x86_64 from rpmforge has depsolving problems
  --> Missing Dependency: perl(AnyEvent) is needed by package memcached-1.4.5-1.el5.rf.x86_64 (rpmforge)
memcached-1.4.5-1.el5.rf.x86_64 from rpmforge has depsolving problems
  --> Missing Dependency: perl(AnyEvent::Handle) is needed by package memcached-1.4.5-1.el5.rf.x86_64 (rpmforge)
memcached-1.4.5-1.el5.rf.x86_64 from rpmforge has depsolving problems
  --> Missing Dependency: perl(YAML) is needed by package memcached-1.4.5-1.el5.rf.x86_64 (rpmforge)
memcached-1.4.5-1.el5.rf.x86_64 from rpmforge has depsolving problems
  --> Missing Dependency: perl(Term::ReadKey) is needed by package memcached-1.4.5-1.el5.rf.x86_64 (rpmforge)

Packages skipped because of dependency problems:
    compat-libevent-11a-3.2.1-1.el5.rf.x86_64 from rpmforge
    memcached-1.4.5-1.el5.rf.x86_64 from rpmforge

The perl modules that its complaining about are already installed.

Any ideas?

  • Any particular reason you are installing this from RPMforge rather than EPEL? – mattdm Dec 27 '10 at 5:44
2

The Perl packages are excluded in the yum configuration due to cPanel. Talk to them for a fix.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.