0

I create WCF service library and i test that working fine on WCF Test client(default). when i host the WCF service in winodws service that time i got the error. I am using windows XP sp3, .Net 3.5 and Visual Studio 2008. i got error.

Error opening host : HTTP could not register URL "http://+:8731/WCFServerDLL/Service1/." Your process does not have access rights to this namespace (see "http://go.microsoft.com/fwlink/?LinkId=70353" for details).

the above link for microsoft i implement the httpcfg. Here i run the "httpcfg.exe set urlacl /u http://localhost:8731/WCFServerDLL/Service1/ /a"

i get the result

HttpSetServiceConfiguration completed with 0. what is the problem i got same error. can you give me a suggation.

1 Answer 1

0

Yeah. READ. What you did, what the error message says. Realized that 8731 is NOT equal to 8000.

See, the error is thatt you dont ahve access rights on port 8731- "http://+:8731/WCFServerDLL/Service1/".

Then you blindly go and assign rights on port 8000 - "httpcfg.exe set urlacl /u http://localhost:8000/WCFServerDLL/Service1/ /a"

Change that and it will be working. Obviously the rights granted must be on the correct URL, which incidentally includes the correct port.

1
  • The error is "http://+:8731/WCFServerDLL/Service1"
    – sivakumar
    Dec 27, 2010 at 13:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .