I'm trying to install a package on my Ubuntu 8.10 server. However, I get this message:

The following packages have unmet dependencies.
webmin: Depends: apt-show-versions but it is not going to be installed
E: Unmet dependencies. Try ‘apt-get -f install’ with no packages (or specify a solution).

So I run apt-get -f install which offers to install apt-show-versions and libapt-pkg-perl. After selecting to install without verification, I get these errors:

Err http://gb.archive.ubuntu.com intrepid/universe libapt-pkg-perl 0.1.22build1
404 Not Found
Err http://gb.archive.ubuntu.com intrepid/universe apt-show-versions 0.13
404 Not Found
Failed to fetch http://gb.archive.ubuntu.com/ubuntu/pool/universe/liba/libapt-pkg-perl/libapt-pkg-perl_0.1.22build1_i386.deb 404 Not Found
Failed to fetch http://gb.archive.ubuntu.com/ubuntu/pool/universe/a/apt-show-versions/apt-show-versions_0.13_all.deb 404 Not Found
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

I've tried running apt-get update and adding --fix-missing as suggested, but neither works. Where do I go from here?

  • @LatinSuD: I am using 8.10 (upgraded from 8.04) - does that mean the packages are messed up in some way? Dec 31, 2010 at 13:36
  • 1
    @LatinSuD: you have that backwards. Intrepid was 8.10 and not LTS, 8.04 was Hardy and is LTS and still supported.
    – DerfK
    Dec 31, 2010 at 17:55
  • I made a couple mistakes in my previous comment. Whatever i cannot see Interpid in any mirror so i think it is outdated and your only path is to upgrade.
    – LatinSuD
    Jan 5, 2011 at 9:05

4 Answers 4


The ubuntu 8.10 is not any more supported. Have a look at this link.

Ubuntu 8.10 (Intrepid Ibex) was released in 30 October 2008 and maintained to 30 April 2010. So, you need to upgrade your server using:

$ sudo do-release-upgrade

But, you need to have update-manager-core package installed.

Otherwise, you may need to re-install a newer version of ubuntu.


The intrepid release is simply not on the archive servers. I don't know the reason for that. But if you want to proceed, you will probably need to upgrade to something newer.


You really should update!!!!! but if you can't right now or want to solve your apt problems so you can update without reinstalling try switching your repos to point to

deb http://old-releases.ubuntu.com/ubuntu/ Ibex main restricted universe multiverse


The package with unmet dependencies is damaged and has to be removed by force. In your case the package is webmin

sudo dpkg -r webmin

There could be more packages with similar problems. They have to be removed one by one. Then try

apt-get update 
apt-get upgrade
apt-get autoremove 
apt-get clean all

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .