VMWare Server 2.0.0 Build 122956

I am having some issues with connecting into a guest VM (Ubuntu linux 4.4.3-4 lucid) running under VMware 2.0 on a windows server host. All connections to and from the VM's work fine, except for FTP. I thought the issue was the FTP daemon at first but it has been ruled out that it is not the daemon or the server itself. When you try to connect to the FTP server from outside of the host OS it fails with a "421 Service not available" but when you try and connect from the local VM or from the host OS the connection goes through fine. I have ran many packet sniffs using wireshark/tcpdump from the VM, the host OS, and the client connecting, the most informative is the host OS. I have attached a PNG of the relavant packets that were captured. I viewed some other network traffic that was sniffed (WWW specifically) and it seems to do the same syn/ack repeating but the user doesnt see any issues.

I have disabled the firewall and the issues persisits, I have tried with specific allow rules to ensure the data is allowed and no changes. It appears like VMware attempts to do the ICMP redirect and it works, but then it vmware repeats the packets sent so you get 3 syn/ack's for every one syn from the client. Also VMWare appears to be attempting to establish an FTP connection between the HOST OS and the GUEST OS, because I see the second SYN sent from the HOST OS to the GUEST to initiate a new connection, and it get the appropriate SYN/ACK followed by an ACK, but the client never sees any of this from its end. EG. syn from client syn/ack from host OS to client syn/ack from guest OS to client syn/ack from host OS to client

The same thing happens when the connection reset is attempted, RST's start being sent and repeated, the server responds with a valid header to continue the FTP handshake but the RST acknowledgement is allready issued and things are closed. I am not 100% if this is a bug in VMware or possibly a VMNetwork missconfiguration.

Does anyone have any thoughts on where exactly the issue could be, things to try to verify or rule out?

Here's picture of the relevant packets sniffed from the host OS:

UPDATE0: I tried enabling "EnableICMPRedirect" and "IPEnableRouter" in the windows registry and tried, I had no sucess with either. UPDATE1: I blocked all traffic from the HOST OS to the client and server on the host OS, I blocked all packets from the host OS on the client and server by mac address and the connection was allowed. What part of vmware could be causing this, would it be a bug in the network "bridge mode" module/driver?


Forgive me if this is too elementary, but if those VM's were originally copied, check your MAC addresses for duplicates.

  • Thank you for the reply. The VM's are not copies but I checked the MAC's just to be sure and there are no conflicting duplicate MAC address's. – user65579 Jan 6 '11 at 13:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.