I have a USB disk which has 2 partitions.It gets mounted automatically in /media

It is the default behavior in the OS (Lucid 10.04 64 bit) that upon connecting a USB (be it thumb drive or hard disk) it will mount it in /media. I have 2 patitions on the USB hard disk as follows

ls -l /media

drwxrwxrwx 2 bond bond  2048 2010-02-12 04:12 HPLAUNCHER
drwx------ 7 bond bond  4096 1970-01-01 05:30 vol1
drwx------ 1 bond bond 20480 2011-01-03 17:43 vol2

I want to share vol2 on nfs

Here is the /etc/exports file entry on nfs server


On the client machine I tried to mount the above nfs volume

mount -t nfs /mnt/nfs

Things worked well upto here.

But I was not able to go inside the mounted volume at the client machine.

Hence I checked the permissions on the folder on nfs server they were as follows

drwx------ 1 bond bond 20480 2011-01-03 17:43 vol2

and the share mounted on client machine which was above only had following permissions

drwx------ 1 client_hostname client_hostname 20480 2011-01-03 17:43 vol2

Considering this to be source of problem I tried to change the permissions at the server

chmod -R 755 /media/vol2 

but this attempt failed. Does any one has any clue as what might be the issue? It appears to be some file system problem.

I checked by mount command the type of file system on USB disk

/dev/sdb2 on /media/vol1 type vfat (rw,nosuid,nodev,uhelper=udisks,uid=1000,gid=1000,shortname=mixed,dmask=0077,utf8=1,flush)
/dev/sdb5 on /media/vol2 type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096,default_permissions)
/dev/sr1 on /media/HPLAUNCHER type iso9660 (ro,nosuid,nodev,uhelper=udisks,uid=1000,gid=1000,iocharset=utf8,mode=0400,dmode=0500)

and the /var/log/syslog shows

Jan  6 10:24:12 bond ntfs-3g[2278]: Mounted /dev/sdb5 (Read-Write, label "vol2", NTFS 3.1)
Jan  6 10:24:12 bond ntfs-3g[2278]: Cmdline options: rw,nosuid,nodev,uhelper=udisks,uid=1000,gid=1000,dmask=0077
Jan  6 10:24:12 bond ntfs-3g[2278]: Mount options: rw,nosuid,nodev,uhelper=udisks,silent,allow_other,nonempty,relatime,fsname=/dev/sdb5,blkdev,blksize=4096,default_permissions
Jan  6 10:24:12 bond ntfs-3g[2278]: Global ownership and permissions enforced, configuration type 1

Where I see ntfs-3g driver in use for the above volume which I want to export on nfs.Can this be the source of my problems? Or I need to check some thing else?


Do you have matching UIDs on the client and server for access (ie, does 'bond' exist on both systems, with the same UID? NFS requires this to enforce the filesystem permissions correctly.

As another test, can you export another path, not on the USB stick successfully?

  • No I do not have matching UIDs on the client and server for access (bond does not exist on both systems).It is not possible to have this some one else will be using that. How ever I was able to resolve this problem by now.I was exporting the files as root and had forgotten no_root_squash option to work. – Bond Jan 7 '11 at 5:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.