Since a month or so ago I inherited responsibility for small network administration for my sins. The domain controller (yes there is only one, and yes I know it is best practice to have two even in a small domain setup) went down overnight and I have been trying all day to get it back up and running. Unfortunately this machine also administers our entire Active Directory setup:

  1. It goes through the BIOS without any errors, nothing whatsoever
  2. It gets into the “select safe mode, safe mode with networking, normal” etc and if you select either of the safe mode options it loads a few files then reboots. If you select normal it just runs for a bit (doesn’t get to the windows splash screen) and then reboots again.
  3. If you select windows repair, it asks for an image to repair too: however it would appear that none was taken that can be used (!!) or one is not being shown.
  4. I have tried repairing the boot sector and the boot configuration using bootrec.exe, both which it says were completed successfully but still it doesn’t work.
  5. I have tried swapping the drives into another server to rule out hardware and that didn’t work either so clearly it’s the OS.
  6. I have tried running chkdsk which ran fine, and also memory check which was also fine.

We do have another machine on the network that was installed as a DC so when we decommission the current infrastructure but when I try and "promote" this to the lead DC then I get “you cannot modify domain or trust information because a PDC emulator cannot be contacted" so I am unable to replicate the Active Directory details.

  • Try booting the Windows CD and selecting the repair options. Cross your fingers that it works, you're pretty close to SOL. – Chris S Jan 5 '11 at 20:34
  • 1
    What is the status of your backups? – Bart Silverstrim Jan 5 '11 at 20:35
  • Chris: thanks for the quick response, sorry I should have added that I already tried the windows repair options, there is no image stored to repair from image (remember this is 2008 server so file/file copy doesnt work as its image based install) so that leaves me command prompt, and memory check as the only other options. – WebSolProv Jan 5 '11 at 20:43
  • I also tried StartRep, and all of the Boot repair options as mentioned above in the thinking it was a boot sector corruption: but to no avail. The only mild progression being the startrep but it just says it cant be recovered automatically and it gives me no pointers what is wrong. – WebSolProv Jan 5 '11 at 20:44
  • Bart: again thanks to you also. There are backups of the data / file shares etc but it would appear the previous sysadmins have not taken any system images or restore points to work from or restore back to. – WebSolProv Jan 5 '11 at 20:45

You could try booting from a linux live CD and mounting the drive so you can scan it for more errors. If you're able to mount the drive successfully and the scan comes back clean, you should be able to at least access/transfer the files that are on that hard drive.

  • That won't help if the corruption is at a different level and his registry files are hosed, though. Can't easily copy files from A to B to restore it like that, to my knowledge. And even if he brought another AD server up, it would be so out of sync he could have serious problems with getting it running properly. If he doesn't have many users he may have to actually rebuild the whole thing from scratch, if there are no backups. – Bart Silverstrim Jan 5 '11 at 20:49
  • Thanks byachna, there are no files on there that I need to keep. All of the shared directories are located on a storageworks servere attached through MSA: they are all fine asides from being locked from users as a result of lack of DC which controls the permissions. Its more the activedirectory that I am worried about, and the DC itself obviously, the CHKDSK didnt find any drive errors so you think the linux live cd would perhaps deduce more logical errors that could be causing the problem? the thing that makes me worry is that I cant see ANY errors giving me a hint as to where I can look :( – WebSolProv Jan 5 '11 at 20:49
  • Bart: I have tried bringing up another machine on the network as the DC but it needs to sync with the PDC / Primary Domain Controller to get the AD data which of course is down. – WebSolProv Jan 5 '11 at 20:51
  • Incidentally I have also tried the sfc.exe /scannow utility as well but that just refuses to do anything. The drives themselves dont appear to be producing any errors, and all status lights arent indicating everything. – WebSolProv Jan 5 '11 at 20:55
  • Does anyone have any further comments? I am trying to upgrade Server 2008 x64 to Server 2008 R2 in the hope that it will jog the problem away, but Windows is refusing to continue the upgrade from disk as I booted from disk. Catch 22: I cant boot into windows normally as it is asking, so what now? – WebSolProv Jan 25 '11 at 13:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.