I have a media server, Windows Server 2008 SP2 running Backup Exec 2010 R2. The SQL and other Windows agents work but I cannot backup the Exchange 2010 server running Windows Server2008 R2. I have the correct license for the Exchange agent - installed on the media server, and I installed Exchange Management tools on the media server.

The 'Microsoft Exchange Database Availability Group' option is greyed out and if I select the server under a new backup job I can expand the 'Microsoft Information Store' option and see the mail database name but showing 0Kb.

When I try to back it up it gives an error displaying: The job failed with the following error: Backup Exec attempted to back up an Exchange database according to the job settings. The database was not found, however. Update the selection list and run the job again.


Have you read the BackupExec Admin Guide, specifically the section on backing up Exchange, and made sure you've got everything in place and configured properly to back up Exchange 2010?

  • 1
    Simple but effective response. RTFM :-) But who reads guides nowadays... – MadBoy Jan 6 '11 at 19:02
  • I know, but with BackupExec there's no substitute for reading the manual. – joeqwerty Jan 7 '11 at 0:51

This smells of a permissions issue to me.

Your service account must be a member of the following Active Directory groups.

  • Administrators
  • Domain Admins

Additionally, make sure your service account is a member of the Exchange Organization Management role group.

To back up databases in a DAG, the remote agent must be installed on all DAG members. To support granular restore, the remote agent must also be installed on all CAS servers in the site.

Source: Backup Exec Administrators Guide (page 1095-ish)


Ben you were the closest, I got it working thanks to help from Gautam Khadse at Symantec. The user used by Backup Exec to do the backup job - in my case a user called backupexec - had to be placed explicitly as a local admin on the Exchange box, regardless of the fact that it had Domain Admin rights (which in my case automatically made this user a local administrator on the Exchange box).

All the other pre-requisites were also followed and the user also had the Exchange Organization Management role. The user's credentials also tested successfully in the new backup job dialogue box. This fix was not in the documentation, but worked for me.

To sum up: Added the backup user explicitly to the local admins group on the Exchange server


I am running backup exec 2010 as well, and I am able to backup our information store from our exchange server.

You stated you have the license and it is installed. From what I read, I assume you have the remote agent installed on the exchange server correct?

My config is the same, remote agent on the exchange server and I am licensed for exchange. So when I create a new backup job I can drill down to the exchange server, drill down from there and select the "information store". Using brick level backup.

I don't see anything on my list about "Microsoft Exchange Database Availability Group"? Am I missing something?

So I guess I am not really answering your question, but possibly asking another. Is there something else I need to be backing up? I have been getting good backups of the information store, and have done restores?

Do make sure though that you have the remote agent installed, then it should see the information store. That as far as I know is what you want backed up.

  • If you're asking another question please do so on in other question (I mean your own). Otherwise it's not gonna get answers :-) DAG was introduced in Exchange 2010. Do you have it or maybe Exchange 2007? – MadBoy Jan 6 '11 at 19:03

Have you tried restarting your machines? Also re-installing the remote agent?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.