I have a Server running Ubuntu 10.10 Server-Edition kvm, and libvirt (both ubuntu-native packages) HDD-Partitioning was done with LVM. Then I created some VMs with Virt-Manager and assigned LVM-Volumes to the VMs.

Now the VMs do not boot. Virt-Manager shows a CPU-Usage of 100% for this Guest and the VNC-Connection states

Booting from Hard Disk

The VM-specific logfiles do not show any abnormality only syslog shows a warning

warning : qemudParsePCIDeviceStrs:1422 : Unexpected exit status '1', qemu probably failed

What can I do to find the error?


Can you try stopping AppArmor "sudo /etc/init.d/apparmor stop; sudo /etc/init.d/apparmor teardown"

then restarting the VM!

  • this also didn't work. I found out, that creating new VMs is no problem. They run as they should. So I suspect Virt-Manager of having done something wrong with my old VM's. I used Virt-Manager to reorder the Disk-Positions and after that nothing worked anymore.
    – markus
    Jan 11 '11 at 11:06

You might want to try switching the disk type, e.g. from virtio to ide. You can virsh dumpxml > guestname.xml, edit the dump file to make the change, destroy and undefine the guest, then create from the edited dump file.

  • As an aside, the guest logfiles have yet to provide me really helpful information when troubleshooting a qemu/kvm problem. This might just be me, but it's one of my few complaints w/ KVM.
    – nedm
    Jan 9 '11 at 9:03
  • I already had the disk type set to SCSI instead of virtio.
    – markus
    Jan 9 '11 at 9:07
  • I'd still switch it to IDE (or even to virtio) to see if it makes a difference. Also, how are the physical disks composing the LVM volumes connected? Are they SATA, running through a PCI/x SATA card by chance? That's one setup I've seen similar (though not identical) errors from.
    – nedm
    Jan 9 '11 at 9:14
  • lspci | grep SATA shows me an Intel onboard SATA-Controller. My current config file: pastebin.com/K8DDtqi5
    – markus
    Jan 9 '11 at 9:35
  • using virtio I get this error: "error: internal error process exited while connecting to monitor: PCI: devfn 24 not available for rtl8139, in use by virtio-blk-pci". using ide does not work at all
    – markus
    Jan 9 '11 at 9:43

Did you ever restart the server after installing libvirt-bin and/or kvm? I have no idea why, but it solved the problem in our case.

  • Yes I did. But it didn't help.
    – markus
    Feb 17 '11 at 10:12
  • I finally ended up creating a new config with VirtManager with the proper disk-order, setting the disk type to SCSI, reloaded the profile and now it works like a charme.
    – markus
    Feb 17 '11 at 10:19

I just had exacly same problem after increasing VM memory resources via virt-manager:

warning : qemudParsePCIDeviceStrs:1422 : Unexpected exit status '1'
qemu probably failed

sitting in my /var/log/messages.log after trying to start VM.
I could not start VM. Since:

sudo service libvirt-bin stop
sudo service libvirt-bin start

didn't work on Debian stable 64 I solved this issue with:

ps -ef | grep libvirtd
sudo kill -9 31416
sudo service libvirt-bin start
ps -ef | grep libvirtd

and then:

sudo virsh start SomeOS

I think this is related to inaccesible volume or VM disk image.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.